hakimjon232
26.12.2021 12:43

решить задачу по программированию на языке с++
Написать программу которая является интернет магазином по покупке обуви
Вам нужно создать несколько классов
1) Обувь
2) Кеды: Обувь
3) Туфли: Обувь
4) Транзакция
Пользователь, когда заходит в ваш магазин, перед ним появляется меню
- Что хотите купить : 1 – кеды, 2 – туфли
Появляется список продуктов(берутся из двух текстовых файлов).
Пользователь выбирает продукт и после появляется во Хотите что - нибудь еще купить ? Y - да, N - нет
Соответственно если да то снова тот же список, если нет то переходит к корзине.
Все транзакции это выбор отдельной обуви, при выборе они должны создаваться.В конце
появится во Вот ваши товары и вот общая стоимость. (попытайтесь визуально сделать в виде чека)
№номер чека(тут зарандомьте)
Товар 1 – цена
Товар 2 - цена
Товар 3 – цена
Итого общ стоимость
- Вы готовы купить ? 1 - да, 2 - нет.Если да то текст «Поздравляем», если нет «То переход в самое
начало и карзину нужно почистить.)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Еленка871
14.06.2022 08:46

Это не знак деления, а двоеточие.  

В программировании знаком деления является косая черта дроби "/".

При выводе данных можно указать, сколько ячеек (знако-мест) на экране следует отвести для выводимого значения. Это бывает полезно, если, например, ты выводишь на экран таблицу. в которой все элементы должны иметь одну ширину.

writeln(x:4:1,' | ',y:5:2);

Здесь под дробное число x (икс) выделяется четыре знако-места. При этом значение икса округляется до одного знака после запятой. Этот один знак будет выводиться в любом случае — даже если икс целый.

Например, если x = 3, то на экран он выведется так: _ 3 . 0

_ — это как бы пробел.

Для значения y (игрек) выделяется пять знако-мест, а округление идет до двух знаков после запятой.

Например: _ 4 . 1 5

0,0(0 оценок)
Ответ:
Дильназ231
27.09.2021 06:45

var M:array[0..15]of integer;

     k, i, sum ,inp : integer;

begin

  for  k := 0 to 15 do begin

      writeln('Введите ', k , ' элемент массива:');

      readln(M[k]);

  end;

   

  for i := 0 to 15 do begin

        if (i mod 2 = 0) then  

        begin

            if (M[i] mod  2 = 0) then

            begin

                 sum := sum + M[i];

            end;

        end;

  end;

   

writeln('Вывод : ' , sum - M[0]);

readln;

end.

Объяснение: ответ к первой части.В общем: в этой программе 0 не считается чётным числом, поэтому 0-вой индекс, даже если его число чётное - не считается . Если вы с этим не согласны то вам всего лишь нужно из этой строчки: writeln('Вывод : ' , sum - M[0]); сделать writeln('Вывод : ' , sum);

Вторая задача :

var M:array[0..15]of integer;

     k, i, sum ,inp : integer;

begin

  for  k := 0 to 15 do begin

      writeln('Введите ', k , ' элемент массива:');

      readln(M[k]);    

  end;

   

  for i := 0 to 15 do begin

        if (i mod 2 <> 0) then  

            sum := sum + M[i];

  end;

   

writeln('Вывод : ' , sum);

readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота