С++ написать программу, которая будет выводить на экран: «введи свой возраст», затем считывать введенное с клавиатуры целое число и выводить на экран правильно законченную фразу: «вам ! число! год/года/лет», если число находиться в промежутке (1-130), обработать возможные ошибки.
{ С использованием цикла FOR } writeln('Используем цикл FOR'); write('Введите стоимость 1-го кг конфет: '); readln(price); for i:=1 to max do begin writeln (i, ' кг. конфет стоят: ', i*price:7:2); end;
{ С использованием цикла REPEAT } i:=1; writeln; writeln('Используем цикл REPEAT'); repeat writeln (i, ' кг. конфет стоят: ', i*price:7:2); i:=i+1; until(i>max);
{ С использованием цикла WHILE } i:=1; writeln; writeln('Используем цикл WHILE'); while(i<=max) do begin writeln (i, ' кг. конфет стоят: ', i*price:7:2); i:=i+1; end; end;
program konfety; var t: real; i: integer; begin WriteLn('Введите стоимость 1 кг конфет (в рублях): '); Read(t); for i := 1 to 10 do WriteLn('Стоимость ', i, ' кг конфет: ', i*t); end.
Смысл такой: - цена 1 кг конфет (вещественный тип real) - счетчик, который будет увеличиваться на единицу после каждого выполнения тела цикла .
WriteLn() выводит на экран строку, которая заключена в кавычки. Не забываем ставить точку с запятой после операций.
Read(t) дает вам возможность вписать, сколько стоит килограмм конфет, и присваивает переменной то значение, которое мы ввели.
Далее идет цикл , который по сути вот что делает: Для каждого целого i от 1 до 10 сделай вот что: Выведи на экран строку 'Стоимость ', потом значение i, потом строку 'кг конфет: ', потом число i умноженное на t
После того, как закончишь обрабатывать все это в последний десятый раз, переходи дальше.
А дальше у нас end (последний end. всегда с точкой).
Конец.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку