Djdjdjdjdjje
17.12.2021 01:05

Объясните смысл программы в паскаль, распишите по действиям что мы делаем в каждой строке, вот : напишите программу, определяющую, лежит ли точка а (ха,уа) на прямой y=kx+l, над ней или под ней program b1; var xa, ya, y, k, x, l: real; begin writeln ('введите координаты точки a > > '); readln (xa, ya); writeln ('введите координаты k и l'); readln (k, l); if ya = k*xa +l then begin writeln ('точка a лежит на прямой') end else if ya> k*xa+l then begin writeln ('точка a лежит над прямой') end else if ya begin writeln ('точка a лежит под прямой') end end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Объяснение:

Схе́ма Го́рнера (или правило Горнера, метод Горнера, метод Руффини-Горнера) — алгоритм вычисления значения многочлена, записанного в виде суммы мономов (одночленов), при заданном значении переменной. Метод Горнера позволяет найти корни многочлена[1], а также вычислить производные полинома в заданной точке. Схема Горнера также является простым алгоритмом для деления многочлена на бином вида {\displaystyle x-c}x-c. Метод назван в честь Уильяма Джорджа Горнера, однако Паоло Руффини опередил Горнера на 15 лет, а китайцам этот был известен еще в XIII веке.

0,0(0 оценок)
Ответ:
Olga831106
29.06.2020 12:18

№1:

Для перевода целой части необходимо умножить разряд числа на соответствующую ему степень разряда.
101 = 2^{2}*1 + 2^{1}*0 + 2^{0}*1 = 4 + 0 + 1 = 5

Для перевода дробной части необходимо разделить разряд числа на соответствующую ему степень разряда
101 = 2^{-1}*1 + 2^{-2}*0 + 2^{-3}*1 = 0.625

 

Аналогично:

№2

101 = 2^{2}*1 + 2^{1}*0 + 2^{0}*1 = 4 + 0 + 1 = 5

101000 = 2^{-1}*1 + 2^{-2}*0 + 2^{-3}*1 + 2^{-4}*0 + 2^{-5}*0 + 2^{-6}*0 = 0.625

 

№3

11001 = 2^{4}*1 + 2^{3}*1 + 2^{2}*0 + 2^{1}*0 + 2^{0}*1 = 16 + 8 + 0 + 0 + 1 = 25

101000 = 2^{-1}*1 + 2^{-2}*0 + 2^{-3}*1 + 2^{-4}*0 + 2^{-5}*0 + 2^{-6}*0 = 0.625

 

№4

10100 = 2^{4}*1 + 2^{3}*0 + 2^{2}*1 + 2^{1}*0 + 2^{0}*0 = 16 + 0 + 4 + 0 + 0 = 20

101 = 2^{-1}*1 + 2^{-2}*0 + 2^{-3}*1 = 0.625

 

 

 Если не понятен значок ^{  } - это степень.

 

 

Вложение к следующему заданию


Переведите из двоичной системы счисления в десятичную : 1) 101,101 2) 101,101000 3) 11001,101000 4)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота