2346573920316
28.05.2020 20:48

Дана квадратная матрица. Составить программу, которая булет заполнять матрицу единицами, а элементы которые будут находиться по периметру должны быть нулями(Паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SeamCard
30.08.2020 14:04

Пишите язык, который вам нужен. Пишу на наиболее вероятном: Pascal.
program massiv;

uses crt;

var A:array[1..10] of integer; s: real; i,k, p: integer;

begin

clrscr;

randomize;

writeln ('задан массив:');

for i:=1 to 10 do

begin

a[i]:=random(100); {задание массива}

s:=s+a[i];{ считаем сразу сумму элементов}

write (a[i]:4); {вывод на экран}

end;

s:=s/10;

for i:=1 to 10 do

if a[i]>s then p:=p+1;

if p mod  2= 0 then {проверка на четность}

                          for i:=1 to 10 do a[i]:=a[i]+i

                             else 

                                        begin

                                        k:=a[5];

                                        a[5]:=a[6];

                                        a[6]:=k; {обмен значений а5 и а6. если считать их центральными элементами, через третью переменную}

                                        end;

writeln; {дабы у вас ничего не слиплось}

for i:=1 to 10 do write (a[i]:4); {вывод полученного массива на экран} 

end.

 

 

 

0,0(0 оценок)
Ответ:
kvaisberg
30.08.2020 14:04

Пишите язык, который вам нужен. Пишу на наиболее вероятном: Pascal.
program massiv;

uses crt;

var A:array[1..10] of integer; s: real; i,k, p: integer;

begin

clrscr;

randomize;

writeln ('задан массив:');

for i:=1 to 10 do

begin

a[i]:=random(100); {задание массива}

s:=s+a[i];{ считаем сразу сумму элементов}

write (a[i]:4); {вывод на экран}

end;

s:=s/10;

for i:=1 to 10 do

if a[i]>s then p:=p+1;

if p mod  2= 0 then {проверка на четность}

                          for i:=1 to 10 do a[i]:=a[i]+i

                             else 

                                        begin

                                        k:=a[5];

                                        a[5]:=a[6];

                                        a[6]:=k; {обмен значений а5 и а6. если считать их центральными элементами, через третью переменную}

                                        end;

writeln; {дабы у вас ничего не слиплось}

for i:=1 to 10 do write (a[i]:4); {вывод полученного массива на экран} 

end.

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота