UdTzgu
22.03.2020 17:09

Напишите программу, которая увеличивает элементы одномерного массива на 10%, а затем сортирует эти элементы методом «пузырька» по убыванию. Выведите результат данных операций в консоль. На Java

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vipmopmop
25.08.2020 01:25

ответ:

uses crt;

var a: array[1..20,1..20] of real;

    n,m,i,j: integer;

    s: real;

begin

    clrscr; randomize;

    write('введите кол-во строк: '); readln(n);

    write('введите кол-во столбцов: '); readln(m);

    for i: =1 to n do

    begin

      for j: =1 to m do

      begin

        a[i,j]: =random(100)/10;

        write(a[i,j]: 4: 1);

      end;

      writeln;

    end;

    for i: =1 to n do

    begin

      s: =0;

      for j: =1 to m do

      s: =s+a[i,j];

      writeln('сумма ',i,'-ой строки: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      for i: =1 to n do

      s: =s+a[i,j];

      writeln('сумма ',j,'-ого столбца: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      if j mod 2 = 0 then  

      begin

        for i: =1 to n do

        s: =s+a[i,j];

        writeln('среднее арифметическое ',j,'-ого столбца: ',s/m: 0: 1);

      end;

    end;

    readln;

end.

объяснение:

0,0(0 оценок)
Ответ:
kirillkleptzov
02.06.2020 13:25

ответ:

объяснение:

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

const n=23; m=40; //n-ряды, m-места

var

  a: array[1..n,1..m] of integer; //зрительный зал

  i,j,k: integer;

begin

  randomize;

  writeln('зрительный зал: ');

  write('м/р');

  for i: =1 to m do write(i: 3);

  writeln;

  for i: =1 to n do begin

    write(i: 3);

    for j: =1 to m do begin

      a[i,j]: =ord(random(10)> 0); write(a[i,j]: 3); //read(a[i,j]); я ввожу гадалкой, т.к. руками вбивать 920 цифирь не входит в мое понятие героизма

    end;

    writeln;

  end;

  repeat

    write('в каком ряду смотреть свободные места? ');

    readln(i);

  until (i> 0) and (i

  k: =0;

  for j: =1 to m do k: =k+ord(a[i,j]=0); //cчитаем свободные места

  write('в ряду ',i);

  if k> 0 then writeln(' есть свободные места в количестве ',k,' шт.') else

  writeln(' свободных мест нет');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота