Misani
07.01.2021 03:53

Напишите программу
Найти количество чисел кратных 9, но не кратных 5 в промежутке от 1 до 100.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ivolapseb
01.07.2020 17:57
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Ответ:
aibar4
04.01.2020 23:21

Первые два блока - просто начало алгоритма и ввод трех чисел x, y и z.

Условная конструкция: если x > y, то в переменную max записывается x, иначе y. В итоге в переменной max будет находится максимум из двух чисел x и y.

Следующая условия конструкция: если z > max (видимо, имелось в виду это, а не m?), то max = z, иначе ничего не меняется. В max теперь будет находиться максимум из x, y, z.

Оставшиеся два блока - вывод max и окончание работы алгоритма.

Этот алгоритм находит максимум из трёх чисел.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота