нурбол5
30.11.2022 12:13

Составить программу. Которая запрашивала бы ввод числа n, отвергала натуральное число, вычисляла n2, n3, n4 и печатала эти значения в одной строке таблицы. Язык программирования C#

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fsjxjnlsjaCn
17.03.2020 20:21

х=7690 - условие

var x, L, M: integer;

begin readln(x);

L:=0;

M:=0;

while x > 0 do begin

1) L:= L + 1 = 1;

M:= M + x mod 10 = 0;

x:= x div 10 = 7 69;

2) L:= L + 1 = 2;

M:= M + x mod 10 = 9;

x:= x div 10 = 7 6;

3) L:= L + 1 = 3;

M:= M + x mod 10 = 15;

x:= x div 10 = 7 ;

4) L:= L + 1 = 4;

M:= M + x mod 10 = 22;

x:= x div 10 = 0;

end;

writeln(L);

write(M);

end.

L = 4; M = 22

Объяснение:

1)L:= L + 1 = 0 + 1 = 1;

M:= M + x mod 10 = 0 + 0 (остаток) = 0;

x:= x div 10 = 7690 : 10 = 769 (остаток 0 здесь не пишется);

2)L:= L + 1 = 1 + 1 = 2;

M:= M + x mod 10 = 0 + 9 (остаток) = 9;

x:= x div 10 = 769 : 10 = 76 (остаток 9 здесь не пишется);

3)L:= L + 1 = 2 + 1 = 3;

M:= M + x mod 10 = 9 + 6 (остаток) = 15;

x:= x div 10 = 76 : 10 = 7 (остаток 6 здесь не пишется);

4)L:= L + 1 = 3 + 1 = 4;

M:= M + x mod 10 = 15 + 7 (остаток) = 22;

x:= x div 10 = 7 : 10 = 0 (остаток 7 здесь не пишется);

0,0(0 оценок)
Ответ:
Denis7788
22.06.2021 03:06
C++
#include <iostream>
#include <cmath>
#include <stdio.h>

using namespace std;
int main() {
int a,b,c,d,r,r2,r3;

cin >> a >> b >> c >> d;

r=min(a,b);
r2=min(r,c);
r3=min(r2,d);

cout << r3;
return 0;
}

Pascal
program Project1;

var a,b,c,d:integer;

begin
readln (a,b,c,d);

if ((a<=b) and (a<=c) and (a<=d)) then begin
writeln (a);
end

else if ((b<=a) and (b<=c) and (b<=d)) then begin
writeln (b);
end

else if ((c<=b) and (c<=a) and (c<=d)) then begin
writeln (c);
end

else begin
writeln (d);
end;

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота