omar28
26.04.2023 04:50

Напишите программу на Python
Ходы коня
На шахматной доске стоит конь. Отметьте положение коня на доске и все клетки, которые он бьет. Клетку, где стоит конь, отметьте английской буквой “K”. Клетки, которые он бьёт, отметьте символами “*”. Остальные клетки заполните точками.

Входные данные

Программа получает на вход два числа — координаты коня на шахматной доске. Каждая координата вводится на отдельной строке. Первое число обозначает номер строки, а второе — номер столбца. Все числа принимают значения от 1 до 8.

Выходные данные

Выведите на экран изображение доски так, как это показано в примере.

Примеры
Ввод
Вывод
4
2
. . . . . . . .
* . * . . . . .
. . . * . . . .
. K . . . . . .
. . . * . . . .
* . * . . . . .
. . . . . . . .
. . . . . . . .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
марьям2789
23.12.2021 17:05

вот и наступили мои долгожданные летние каникулы! На этих каникулах я поеду на море. На море очень весело, там можно купаться , загарать, играть в песок.Обычно на море едит не только моя семья но и друзья и наши родственники. Лето может быть интересным даже в деревне у бабушки и дедушки. Допустим в деревне есть много друзей , там можно погулять, поиграть со своими деревенскими друзьями, и вкусно поесть.Летние каникулы самые длинные каникулы и ты сможешь отдыхать 3 месяца, чему я даже очень рад(а) , так как ты все сможешь успеть .

Объяснение:

ну как то так

0,0(0 оценок)
Ответ:
Алекс23102027
03.06.2020 05:36

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

56

57

58

59

60

61

62

63

64

65

var f1,f2,f3:text;

   n,i,a,b:integer;

begin

//создадим исходные файлы, можно вынести в отдельную программу

//или создать файлы вручную

randomize;

assign(f1,'f1.txt');

rewrite(f1);

assign(f2,'f2.txt');

rewrite(f2);

write('Сколько чисел ввести в первый файл n=');

readln(n);

writeln('Содержание файла f1:');

a:=1;

for i:=1 to n do

begin

 a:=a+random(5);

 write(f1,' ',a);

 write(' ',a);

end;

writeln;

write('Сколько чисел ввести во второй файл n=');

readln(n);

writeln('Содержание файла f2:');

a:=1;

for i:=1 to n do

begin

 a:=a+random(5);

 write(f2,' ',a);

 write(' ',a);

end;

writeln;

reset(f1);

reset(f2);

assign(f3,'f3.txt');

rewrite(f3);

//если не конец файла, то читаем числа иначе создаем барьер из

//максимально возможного целого числа

if not eof(f1) then read(f1,a) else a:=maxint;

if not eof(f2) then read(f2,b) else b:=maxint;

while (a<maxint) or (b<maxint) do//пока оба файла не кончились

begin

 if (a<=b) and (a<maxint) then //если 1<=2

  begin

   write(f3,' ',a);//1 пишем в файл 3

   if not eof(f1) then read(f1,a) else a:=maxint;//если не конец 1,

                                                 //то читаем следующее , иначе барьер

 end

 else if b<a then //иначе если 2<1 то же но со 2 файлом

  begin

   write(f3,' ',b);

   if not eof(f2) then read(f2,b) else b:=maxint;

 end;

end;

reset(f3);//смотрим что получилось

writeln('Слияние файлов:');

while not eof(f3) do

begin

 read(f3,a);

 write(' ',a);

end;

close(f1);

close(f2);

close(f3);

end.

Объяснение:

Вроде бы так, я не слишком в этом хорош.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота