Kiber04ек
01.02.2022 03:06

Васе поручили составить программу-психологический тест, которая бы определяла особенности личности по выбранной геометрической фигуре.
Заполните недостающие места в Васиной программе.

Program Psiholog_test;
1 .
f: 2 . ;
3 .
4 . ('Выберите одну из фигур: треугольник, зигзаг, круг, прямоугольник');
5 . (6 .);
7 . (f='треугольник') 8 . (f='Треугольник') 8 . (f='ТРЕУГОЛЬНИК')
9 .
10 . ('Вы сильная личность, весьма уверенные в себе и деятельные. Не любят сидеть на месте, стремитесь всегда находиться в гуще событий.')
11 .
7 . (f='зигзаг') 8 . (f='ЗИГЗАГ') 8 . (f='Зигзаг')
9 .
10 . (' Вы творчсекая и креативная личность, творец, генератор идей')
11 .
7 . (f='круг') 8 . (f='Круг') 8 . (f='КРУГ')
9 .
10 . (' ВЫ крайне контактные и доброжелательные представители рода человеческого, занимающие позицию миротворца в любых конфликтах.')
11 .
7 . (f='прямоугольник') 8 . (f='Прямоугольник') 8 . (f='ПРЯМОУГОЛЬНИК')
9 .
10 . (' Выбор прямоугольника в качестве основной фигуры может свидетельствовать о непоследовательности, склонности к принятию импульсивных решений, непунктуальности и нервозности. Настроение человека-прямоугольника может многократно меняться даже в течении одного дня, что влечет за собой и изменение его поведения.')
11 .
12 . ('Вы не указали ни одной из перечисленных фигур, либо написали с ошибкой');
13 .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
borenka
07.05.2020 14:19
Вот решение на C++:

#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;

int main()
{
int n=0;
cout <<"Введите размер массива: ";
cin >>n;
if (n<1)
{
cout <<"Массив не может быть пустым!";
return 1;
}

int a[n];
srand(time(0));
for (int i=0; i<n; i++)
{
int r=rand()%271-100;
a[i]=r;
}

int min=170;
for (int i=0; i<n; i++)
{
if ((a[i]>0) and (a[i]<min)) min=a[i];
}

cout <<"Минимальный положительный элемент иассива: " <<min <<endl;

return 0;
}
0,0(0 оценок)
Ответ:
рол140
08.04.2022 15:31
Const n = 10;
var a:array[1..n]of integer;
  min,imin,i,oldmin:integer;
begin
  //Заполнение массива значениями в диапазоне
  //от -100 до 100
  //и одновременно находим минимальный элемент элемент
  min:=100;
  for i:=1 to n do begin
    a[i]:=random(201)-100;
    if a[i]<= min then
    begin
      min:=a[i];
      imin:=i;//Запомним index минимального
    end;
    write(a[i]:5);
  end;
  writeln;
 
  //В цикле сдвигаем элементы массива
  //до индекса минимального включительно на
  //одну позицию вправо
  for i:=imin downto 2 do
    a[i]:=a[i-1];
    a[1]:=min;
  //вывод элементов массива
  for i:=1 to n do write(a[i]:5);
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота