Sa6ok1
18.01.2020 17:11

Напишите программу на Python
Список квадратов
Дано число N. Выведите N квадратов чисел от 1 до N (включительно) в формате [1, 4, 9, 16,…, N**2]. Используйте функцию print() для вывода списка.

Входные данные:

В одной строчке дано натуральное число N≤200.

Выходные данные:

Список квадратов в указанном формате.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
PandaVo
24.08.2020 22:04

N = int(input())

arr = [0] * N

for i in range(1,N + 1):

   arr[i - 1] = i ** 2

print(arr)

1 строка - ввод числа N

2 строка - создание массива на N элементов, заполненных нулями

3 строка - цикл на N шагов, где i будет изменяться от 1 до N включительно

4 строка - массивы нумеруются с 0, так что i - 1. Заполнение массива квадратами

5 строка - вывод. Если вывести массив такой командой, то он выведется в нужном формате

0,0(0 оценок)
Ответ:
lolshowsasdasfd
24.08.2020 22:04

N = int(input())

print([i**2 for i in range(1, N+1)])

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота