va1k
28.03.2023 13:12

7) Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно. Вот она:

var x, y: real; begin readln(x, y);

if x <= 1 then if y <= 1 then

if x*x + y*y <= 1

then write('принадлежит')

else write('не принадлежит');

end.

​


7) Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kopechenkina
11.10.2021 06:25

Обилие инструментов интернет-маркетинга вынуждает компании искать новые эффективные реализации интернет-коммуникаций с клиентами. Одним из таких является маркетинг в социальных сетях SMM, под которым подразумевается совокупность мероприятий, направленных на использование социальных медиа, таких как социальные сети, блоги, форумы, фотои видеохостинги и т.д., в качестве каналов продвижения. Это позволяет компаниям выделиться из большого количества конкурентов, привлечь потенциальных потребителей, повысить уровень лояльности клиентов, а также заметно снизить затраты на интернет-рекламу.

Объяснение:

Social Media Marketing- это комплекс мероприятий по использованию разновидных соц. сетей, таких как: Facebook, Instagram, Одноклассники. ru, в качестве каналов для продвижения компаний, их продукции, услуг, которые они предоставляют и решения других бизнес-задач.

0,0(0 оценок)
Ответ:
dendenisenko2
12.04.2021 11:39
Const
  n=8;
var
  aNam, aFam, aDat: array[1..n] of string;
  i: integer;

begin
  aNam[1]:='Олег'; aFam[1]:='Бубенков'; aDat[1]:='1993';
  aNam[2]:='Игорь'; aFam[2]:='Бросов'; aDat[2]:='1991';
  aNam[3]:='Тимур'; aFam[3]:='Наружный'; aDat[3]:='1961';
  aNam[4]:='Анастасия'; aFam[4]:='Боброва'; aDat[4]:='1985';
  aNam[5]:='Михаил'; aFam[5]:='Тапаров'; aDat[5]:='1957';
  aNam[6]:='Евгений'; aFam[6]:='Костарева'; aDat[6]:='1992';
  aNam[7]:='Мария'; aFam[7]:='Никитин'; aDat[7]:='1977';
  aNam[8]:='Ксения'; aFam[8]:='Бабенкова'; aDat[8]:='1978';
  writeln('Лица, чьи фамилии начинаются на букву "Б"');
  for i := 1 to n do
    if aFam[i][1] = 'Б' then
      writeln(aNam[i],' ',aFam[i], ' (', aDat[i], ')')
end.

тестовый прогон:

Лица, чьи фамилии начинаются на букву "Б"
Олег Бубенков (1993)
Игорь Бросов (1991)
Анастасия Боброва (1985)
Ксения Бабенкова (1978)

Возможна также более "современная" запись программы

const
  n = 8;

type
  tP = record
    Nam: string;
    Fam: string;
    Dat: string
  end;

var
  M: array[1..n] of tP;
  i: integer;

begin
  with M[1] do begin Nam := 'Олег'; Fam := 'Бубенков'; Dat := '1993' end;
  with M[2] do begin Nam := 'Игорь'; Fam := 'Бросов'; Dat := '1991' end;
  with M[3] do begin Nam := 'Тимур'; Fam := 'Наружный'; Dat := '1961' end;
  with M[4] do begin Nam := 'Анастасия'; Fam := 'Боброва'; Dat := '1985' end;
  with M[5] do begin Nam := 'Михаил'; Fam := 'Тапаров'; Dat := '1957' end;
  with M[6] do begin Nam := 'Евгений'; Fam := 'Костарева'; Dat := '1992' end;
  with M[7] do begin Nam := 'Мария'; Fam := 'Никитин'; Dat := '1977' end;
  with M[8] do begin Nam := 'Ксения'; Fam := 'Бабенкова'; Dat := '1978' end;
  writeln('Лица, чьи фамилии начинаются на букву "Б"');
  for i := 1 to n do
    With M[i] do begin
      if Fam[1] = 'Б' then
        writeln(Nam, ' ', Fam, ' (', Dat, ')')
    end
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота