anutka2018
19.09.2020 14:33

Написать программу оптимизации раскройки листа С++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
seetneek
25.04.2022 07:57
1) var a:array[1..10] of real;
i:integer;

begin

randomize;
for i:=1 to 10 do begin
a[i]:= random(200) -100;
write(a[i]:5); end;

writeln;

for i:=1 to 10 do 
if a[i]>=0 then a[i]:=a[i]/2 else a[i]:=i;
write(a[i]:5);

end.

2) var a:array[1..1000] of real;
s1,s2:real;
i,n:integer;
begin
write('Введите кол-во элементов: '); readln(n);
writeln('Введите элементы массивы: '); 
for i:=1 to n do
read(a[i]);

s1:=0; s2:=0;
for i:=1 to n do
if odd(i) then s1:=s1+a[i] else s2:=s2+a[i];

writeln('Сумма элементов с четными номерами: ',s2);
writeln('Сумма элементов с нечетными номерами: ',s1);
end.
0,0(0 оценок)
Ответ:
DobinaDaria1
25.04.2022 07:57
1) var a:array[1..10] of real;
i:integer;

begin

randomize;
for i:=1 to 10 do begin
a[i]:= random(200) -100;
write(a[i]:5); end;

writeln;

for i:=1 to 10 do 
if a[i]>=0 then a[i]:=a[i]/2 else a[i]:=i;
write(a[i]:5);

end.

2) var a:array[1..1000] of real;
s1,s2:real;
i,n:integer;
begin
write('Введите кол-во элементов: '); readln(n);
writeln('Введите элементы массивы: '); 
for i:=1 to n do
read(a[i]);

s1:=0; s2:=0;
for i:=1 to n do
if odd(i) then s1:=s1+a[i] else s2:=s2+a[i];

writeln('Сумма элементов с четными номерами: ',s2);
writeln('Сумма элементов с нечетными номерами: ',s1);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота