Danyaukos
22.04.2023 15:39

Составить программу нахождения произведения нечетных чисел от 1 до 100 (цикл с постусловием)
Составить программу нахождения суммы четных от 2 до 100

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
JollyWolf
15.10.2020 09:32

Т.к. требуется использовать цикл until, то значит требуется код на языке Паскаль.

1) цикл for

program p_for

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  p := 1;//начальное значение

  for i := 1 to n do  

     p := p * i;

  writeln(p);

end.  

2) цикл while

program p_while

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  while i <= n do  

  begin

     p := p * i;

     i := i + 1;

 end;

 writeln(p);

end.  

3) цикл until

program p_until

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  repeat

     p := p * i;

     i := i + 1;

  until i > n;

  writeln(p);

end.  

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота