Artur1Khasanov
04.07.2021 08:13

На Python
Треугольник Паскаля
Даны два числа n и m. Создайте массив n×m и заполните его по следующим правилам:

Числа, стоящие в строке 0 или в столбце 0 равны 1 (A[0][j] = 1, A[i][0] = 1).
Для всех остальных элементов массива A[i][j] = A[i-1][j] + A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него.
Входные данные

Вводятся два натуральных числа n и m, не превышающих 100.

Выходные данные

Выведите данный массив на экран.

Примеры
Ввод
Вывод
3 3
1 1 1
1 2 3
1 3 6

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
chalavek
15.10.2020 08:20

n, m = map(int, input().split())

pascal = [[1] * n for i in range(m)]

for i in range(1, m):

   for j in range(1, n):

       pascal[i][j] = pascal[i-1][j] + pascal[i][j-1]

for i in range(len(pascal)):

   print(*pascal[i])

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота