pavunoxe
08.08.2020 19:03

Написать программу нахождения суммы и произведения всех трехзначных чисел кратных 3!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dima1234567y
09.06.2020 16:58

program raf105;

var i,sum,pro,a:integer;

begin

writeln('Вводите 5 чисел по очереди');

pro:= 1;

 for i:=1 to 5 do

 begin

  readln(a);

  if (a>=100) and (a<=999) and ((a mod 3)=0)

    then

    begin

    sum+= a;

    pro*= a;

    end;

  end;

writeln('Сумма трёхзначных  чисел кратных трём: ',sum);

writeln('Произведение трёхзначных  чисел кратных трём: ',pro);

end.

Язык PascalABC

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота