vano1399
09.01.2022 18:20

Составить программу ввода с клавиатуры N целых чисел
Program P1;
const n=5;
var x,i:integer;
begin
for i:=1 to n do
readln(x);
end.


Составить программу ввода с клавиатуры N целых чисел Program P1; const n=5; var x,i:integer; begin

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ксю882
30.12.2021 01:53
//Dev-C++ 4.9.9.2

//а
#include <iostream>
using namespace std;

const int n=10;

int main(){
         int ar[n];
         int arsub[n];
         int m=0;
         cout<<"Enter m:";
         cin>>m;
         cout<<"Enter array:"<<endl;
         for(int i=0;i<n;i++)
          cin>>ar[i];
         for(int i=0;i<m;i++)
          arsub[i]=ar[i];
         for(int i=0;i<n-m;i++)
          ar[i]=ar[i+m];
         for(int i=0;i<m;i++)
          ar[i+(n-m)]=arsub[i];
         cout<<"Final array"<<endl;
         for(int i=0;i<n;i++)
          cout<<ar[i]<<' ';
        cin.get();
        cin.get();
 return 0;
}

//б
#include <iostream>
using namespace std;

const int n=10;

int main(){
         int ar[n];
         int arsub[n];
         int k,k1=0;
         cout<<"Enter k:";
         cin>>k;
         cout<<"Enter array:"<<endl;
         for(int i=0;i<n;i++)
          cin>>ar[i];
         for(int i=n-k;i<n;i++){
          arsub[k1]=ar[i];k1++;}
         for(int i=n;i>=k;i--)
          ar[i]=ar[i-k];
         for(int i=0;i<k;i++)
          ar[i]=arsub[i];
         cout<<"Final array"<<endl;
         for(int i=0;i<n;i++)
          cout<<ar[i]<<' ';
        cin.get();
        cin.get();
 return 0;
}
0,0(0 оценок)
Ответ:
122519
28.08.2022 15:00
//Pascal ABC.NET 3.1 сборка 1219

Var
 f:text;
 ars:array of string;
 s,s1:string;
 min,n,i:integer;
begin
n:=1;
min:=integer.MaxValue;
assign(f,'text.txt');
reset(f);
while not(Eof(f)) do
 begin
  readln(f,s);
  s1:=s;
  s:=s.Trim;
  i:=1;
  while i<>length(s) do
    if (s[i]=' ') and (s[i+1]=' ') then delete(s,i,1) else inc(i);
  if ((s.split).length<=min) and ((s.split).length<>0) then
  begin
   if (s.split).length=min then
    begin
     inc(n);
     setlength(ars,n);
     ars[n-1]:=s1;
    end
    else
    begin
     n:=1;
     setlength(ars,n);
     ars[n-1]:=s1;
    end;
    min:=(s.split).length;
   end;
  end;
close(f);
assign(f,'text1.txt');
rewrite(f);
for i:=0 to n-1 do
writeln(f,ars[i]);
close(f);
end.

Содержимое файла text.txt:
Хей патимейкер
уличный
денсер
шейкер                   шейкер
Содержимое файла text1.txt:
уличный
денсер
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота