fvrvdv
29.05.2020 05:21

Дан целочисленный массив из 40 элементов, все элементы которого – целые числа в интервале от -500 до 500. Напишите программу, которая находит сумму всех отрицательных элементов массива, которые кратны первому элементу (делятся нацело на первый элемент). Гарантируется, что первый элемент массива отрицательный.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sasha808621
27.05.2021 02:28

1) Считываем n и просто в цикле по k от 1 до n прибавляем к текущей сумме новое слагаемое k²:

Код (Python 3):

n = int(input())

s = 0

for k in range(1, n + 1):

   s += k ** 2

print(s)

Пример ввода:

3

Пример вывода:

14

2) Аналогично, только считаем произведение, а не сумму.

Код (Python 3):

n = int(input())

p = 1

for k in range(1, n + 1):

   p *= k

print(p)

Пример ввода:

3

Пример вывода:

6

3) Тут соединяем вместе вычисление n! и суммирование.

Код (Python 3):

n = int(input())

p = 1

s = 0

for k in range(1, n + 1):

   p *= k

   s += p

print(s)

Пример ввода:

3

Пример вывода:

9

0,0(0 оценок)
Ответ:
foma2004korol
22.05.2021 14:20

11. при полном форматировании гибкого диска…
1) стираются все данные

12. В многоуровневой иерархической файловой системе ...
1) Файлы хранятся в системе, представляющей собой систему вложенных папок

13. Путь к файлу:
2) это последовательность из имен каталогов, разделенных знаком «\»;

14. В процессе архивации файлы…
1. Сжимаются без потери информации

15. В процессе дефрагментации диска каждый файл записывается:
3) Обязательно в последовательно расположенных секторах

16. Драйверы устройств:
2) это программные средства, предназначенные для подключения устройств ввода/вывода;

17. Прикладные программы
1) Программы, предназначенные для решения конкретных задач

18. Операционная система выполняет функции:
2) организации диалога с пользователем, управления аппаратурой и ресурсами компьютера;

19. В процессе загрузки операционной системы происходит:
3) Последовательная загрузка файлов операционной системы в оперативную память

20. Системный диск необходим для:
1) Загрузки операционной системы

21. Вершиной иерархической системы папок графического интерфейса Windows является папка:
4. Рабочий стол

22. Диалоговое окно в Windows предназначено для
1) диалога между пользователем и компьютером;

23. В Windows не существует
2) окон тестирования;

24. Компьютерные вирусы это…
1) Программы, которые могут размножаться и выполнять вредные действия по уничтожению программ и данных

31. Все компьютерные изображения разделяют на два типа:
1. растровые и векторные

32. Растровое изображение создается с использованием…
1. точек различного цвета (пикселей)

33. Векторные изображения формируются из…
1. объектов, которые называются графическими примитивами

34. Для обработки цифровых фотографий и отсканированных изображений наилучшим средством служит…
1. растровый графический редактор

35. Для создания рисунков, схем и чертежей наилучшим средством служит…
2. векторный графический редактор

36. Форматы графических файлов определяют …
и форму хранения информации в файле

37. В векторном графическом редакторе нарисованный объект…
1. Продолжает сохранять свою индивидуальность, и его можно масштабировать и перемещать по рисунку

38. Наиболее распространенными приложениями для разработки презентаций является…
1. Microsoft Power Point

39. Файлы презентаций могут сохраняться в формате…
1. ppt

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота