katmoxie
26.07.2021 07:03

Сделать с Напишите программу: использую компоненты Button, Stringgrid, label найти сумму четных чисел, стоящих на главной диагонали двумерного массива, размерностью 5x5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Рад1111111
03.08.2020 16:45

using System;

class Program

   {

       static void Main(string[] args)

       {

           Console.WriteLine("Введите координату x точки");

           double x = int.Parse(Console.ReadLine());

           Console.WriteLine("Введите координату y точки");

           double y = int.Parse(Console.ReadLine());

           Console.WriteLine("Введите радиус");

           double r = int.Parse(Console.ReadLine());

 

           double d = Math.Sqrt(Math.Pow(-x, 2) + Math.Pow(-y, 2));

           Console.WriteLine(d);

           if (d < r){

               Console.WriteLine("Да");}

           else if (d == r){

               Console.WriteLine("На границе");}

           else{

               Console.WriteLine("Нет");}

           Console.ReadKey();

       }

   }

0,0(0 оценок)
Ответ:
sasasnikas
03.08.2020 16:45

using System;

class Program

   {

       static void Main(string[] args)

       {

           Console.WriteLine("Введите координату x точки");

           double x = int.Parse(Console.ReadLine());

           Console.WriteLine("Введите координату y точки");

           double y = int.Parse(Console.ReadLine());

           Console.WriteLine("Введите радиус");

           double r = int.Parse(Console.ReadLine());

 

           double d = Math.Sqrt(Math.Pow(-x, 2) + Math.Pow(-y, 2));

           Console.WriteLine(d);

           if (d < r){

               Console.WriteLine("Да");}

           else if (d == r){

               Console.WriteLine("На границе");}

           else{

               Console.WriteLine("Нет");}

           Console.ReadKey();

       }

   }

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота