sakdkk
21.08.2020 01:40

Написать программу для решения . дана строка, содержащая текст на языке, и некоторая буква. подсчитать, сколько слов начинается с указанной буквы. не копируйте существующие, не работают

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
FaceSwapLive
09.06.2020 15:16

program raf105;

var

 s:string;

 b:char;

 o,i:integer;

begin

write('Введите строку: ');

readln(s);

write('Введите искомую букву: ');

readln(b);

s:= lowercase(s);

b:= lowercase(b);

if s[1] = b

 then o+=1;

for i:=2 to length(s) do

 if (s[i]=b) and (s[i-1]=' ')

   then o+= 1;

writeln('С буквы "',b,'" начинается ',o,' сл.');

end.

Язык PascalABC

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота