Школа5101
31.08.2020 10:25

Вычислите значение по фрагменту программы
var k, i:ineger;
begin
k:=2;
for i:=0 to 2 do
k:3*k+i;
writeln(k);
end

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Rashidleo
16.02.2020 17:45

Код ниже.

Объяснение:

Для подсчета длины отрезка, нужно знать 4 координаты. А(x;y) и B(x;y).

По формуле L = √(X²+Y²) = √ ((Xb-Xa)²+(Yb-Ya)²) мы можем подсчитать длину любого отрезка по известным координатам.

Код:

import math

a = input('Входные данные: ')

s = a.split(' ')

print("Выходные данные: ",math.sqrt(math.pow(float(s[2]) - float(s[0]),2)+math.pow(float(s[3]) - float(s[1]),2)))

Импортируем модуль math для упрощения жизни и себе и людям. Задаем переменную к которой присваиваем значения введенные с клавиатуры в таком формате (Xa(пробел)Ya(пробел)Xb(пробел)Yb(пробел)) например у нас есть 2 точки А с координатами (1;2) и B(3;4) тогда ввод будет такой: "1 2 3 4"

Дальше преобразуем строку в список с разделителем "пробел"

И дальше идет формула, которую записал выше. Float вместо Int потому что значения могут быть с плавающей точкой.

0,0(0 оценок)
Ответ:
Ангелина0611
08.11.2022 10:34

1) В том, что у вас есть данные и вам их надо отсортировать в каком-либо порядке или критерию.

2) Когда нужно отсортировать массив по возрастанию. От меньшего к большему числу.

3) В том, что вы получаете максимум скорости, использую минимум ресурсов. Времени меньше занимает, эффективней.

4)  sorted. Ну и можно сортировать через filter, но могу ошибаться.

5) Для сортировки массива, от меньшего к большему.

6) Наибольший элемент массива ставится на своё место в конце массива рядом с предыдущим «наибольшим элементом», а наименьший элемент перемещается на одну позицию к началу массива («всплывает» до нужной позиции, как пузырёк в воде — отсюда и название алгоритма).

7) Алгоритм состоит из повторяющихся проходов по сортируемому массиву. За каждый проход элементы последовательно сравниваются попарно и, если порядок в паре неверный, выполняется обмен элементов

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота