lera645
10.02.2021 13:00

написать программу в паскале От дома семьи Ивановых до дачи – k километров. За время поездки на дачу (туда и обратно) Ивановы тратят v литров бензина. Стоимость одного литра – r рублей. Какую сумму нужно потратить на бензин перед поездкой в соседний город, расстояние до которого – L км.?
k, v, r L вводятся пользователем с клавиатуры
(ответ можно в виде текста скопировать из самого паскаля) ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Yuliaddd
14.09.2020 20:23

pascal

Объяснение:

var

 k, v, r, L : real;

begin

 Write('Введите расстояние до дачи k: ');

 ReadLn(k);

 Write('Расход в литрах v: ');

 ReadLn(v);

 Write('Введите стоимость бензина за литр r: ');

 ReadLn(r);

 WriteLn('*** Расход равен ', v/(2*k):2, ' л/км ***');

 Write('Введите расстояние до города L: ');

 ReadLn(L);

 WriteLn('Для поездки в город потребуется заправить ', (v*L)/k:2, ' литров бензина стоимостью ', (v*L)/k*r:2, ' руб.');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота