Slendergirl345
15.10.2021 02:55

Составить программу с подпрограммой процедурой (на 13 строк) без параметров для вывода на экран следующего изображения (в первой и последней линии 55 элементов в линии):

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
oleglebedev90
21.10.2020 20:31

var

 a: array of integer;

 n, i, maxpar, minn: integer;

begin

 Write('Введите размер массива N: '); ReadLn(n);

 SetLength(a, n);

 randomize;

 minn := 51;

 WriteLn('Массив:');

 for i := 0 to n - 1 do

 begin

   a[i] := random(50) + 1;

   Write(a[i], ', ');

   if (a[i] < minn) and (a[i] mod 2 = 1) then minn := a[i];

 end;

 WriteLn;

 Sort(a);

 for i := 0 to n - 2 do

   if a[i] = a[i + 1] then maxpar := a[i];

 if maxpar <> 0 then WriteLn('Максимальный парный элемент равен ', maxpar)

    else WriteLn('В массиве нет парных элементов');

 WriteLn('Минимальный нечетный элемент равен ', minn);

end.

Объяснение:

0,0(0 оценок)
Ответ:
ева470
19.04.2021 03:30

var

 a: array[,] of integer;

 m, n, i, j, k, sum: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 k := - 1;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(100);

     Write(a[i, j]:4);

   end;

   WriteLn;

 end;

 for i := 0 to m - 1 do

    if (a[i, 1] > a[i,0]) and (k = -1) then k := i;

 if k = -1 then

 begin

   WriteLn('Нет строк, у которых второй элемент больше первого');

   exit;

 end;

 for j := 0 to n - 1 do

    if (a[k, j] mod 2 = 1) then sum := sum + a[k, j];

 WriteLn('Сумма нечетных чисел строки, у которой второй элемент больше первого, равна ', sum);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота