камран12
18.08.2020 03:57

с программированием:
Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.

Входные данные
Входная строка содержит произвольную последовательность символов.

Выходные данные
Программа должна вывести последнее слово этой строки.

Примеры
входные данные
Abra babra cadabra
выходные данные
cadabra

Сделал похожую программу, только там нужно было вывести первое слово строки, вот ее код:

program p66;// название программы
var s:string;// описание переменной s (строки)
begin//начало блока программы
read(s);//ввод данных (строки)
if pos(' ',s)<>0 then //оператор выбора определяющий из одного слова строка или нет, если pos равно 0, то слово одно
write (copy(s,1,Pos(' ',s)-1))//если нет то вывод копии строки с 1 символа по позицию пробела минус 1 символ
else write (s)//если да то вывод заданной строки
end.//конец блока программы

С программой, где нужно вывести последнее слово возникла проблема написать её.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Tata270204
20.07.2021 19:29
Ну вот, пока без комментариев по 1му вопросу. балы можете не добавлять.
Только тут ведется просмотр всего массива от B[1, 1] до B[n, m]
чтобы начинать просмотр скажем с [10, 10] надо вначале i j присвоить 10, и при переходе к следующему столбцу после приращения j на 1,устанавливать i:=10
 Далее что нужно, чтобы переделать его во 2е задание. Принцип пробега по массиву не меняется. Но теперь вместо min и max будем работать с рабочими переменными SUM и Pr. В SUM накапливаем сумму положительных. Начальное значение можно взять равное нулю.
Затем пробегаем по циклу сравниваем текущий элемент B[i, j] c 0 если B[i, j]>0, то добавляем его в сумму SUM:=SUM+B[i, j]
В противном случае переходим к следующему элементу.
Сложнее будет с произведением. Механизм накопления можно реализовать аналогично а вот какое присвоить начальное значение. 0? ну тогда, что бы мы не нашли произведение с 0 будет 0. 1? а вдруг вообще нет отрицательных элементов, а у нас произведение получится равным 1.
 Мне кажется надо сначала присвоить ему значение 0. А затем при пробежке по массиву при нахождении отрицательного числа сравнить произведение Pr с нулем
Pr=0? да тогда переопределяем его так: Pr:=B[i, j] (присваем ему значение найденного отрицательного элемента) .
Pr≠0? тогда переопределяем его так: Pr:=Pr*B[i, j]

P.S. И все-таки лучше уточнить у преподавателя, к чему относится отрезок. Т.е. это диапазон индексов поиска i, j? Или все же диапазон возможных значений элементов массива B[i, j]. Хотя можно выбрать один из вариантов и самому и оговорить его по ходу решения.(По-моему проще принять это как диапазон возможных значений элементов массива.)
На мой взгляд в условии следовало это оформить отдельным предложением. Например:
Числовые значения элементов массива принадлежат отрезку [-100; 100].
0,0(0 оценок)
Ответ:
laswsc11
22.06.2020 04:34

Електронні таблиці можуть містити тисячі рядків і сотні стовчиків (або навпаки залежно від обраного користувачем подання даних). У таблиці, яку неможливо відобразити повністю на екрані монітора, знаходити потрібну інформацію, навіть за умови її попереднього сортування може виявитися нелегкою справою. У переважній більшості випадків користувача цікавлять дані, що відповідають певному набору умов. Електронні таблиці надають користувачу можливість приховати ті області таблиці, дані в яких цим умовам не відповідають. Такий споcіб відображення даних в електронній таблиці називають фільтруванням.

Фільтрування — це вибір даних у електронній таблиці, що відповідають певним умовам

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота