Lastivka2016
02.02.2022 03:20

Написать программу сортировка одномерного массива методом пузырька.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ппчуп
20.02.2022 16:06

1 задача:

import math

a=int(input())

b=int(input())

if(math.fabs(a+b)>20):

   print(math.pow(a,2))

else:

   b=math.fabs(b)

   print(math.sqrt(b))

2 задача:

a=int(input())

if a == 5:

   print("Отлично")

elif a == 4:

   print("Хорошо")

elif a == 3:

   print("Удовлетворительно")

elif a == 2:

   print("Плохо")

elif a == 1:

   print("Отвратительно")

else:

   print("Это не оценка")

3 задача:

x=int(input())

y=int(input())

a=int(input())

b=int(input())

a7 = a%x

b7 = b%y

if(a7>b7):

   print("7A")

else:

   print("7Б")

4 задача:

import math

print("Введите интервал")

a=int(input())

b=int(input())

while(a<=b):

   if a<100:

       r=13*math.pow(a,2)

       print("X=" + str(a) + " y=" + str(r))

   elif a>100:

       r=math.pow(a,3)-100

       print("X=" + str(a) + " y=" + str(r))

   else:

       r=30-(a/(a-5))

       print("X=" + str(a) + " y=" + str(r))

   a=a+1

5 задача:

import math

print("Введите интервал")

a=int(input())

b=int(input())

while(a<=b):

   if a<4:

       r=3*a-7

       print("X=" + str(a) + " y=" + str(r))

   else:

       r=5*math.pow(a,2)

       print("X=" + str(a) + " y=" + str(r))

   a=a+1

Объяснение:

0,0(0 оценок)
Ответ:
Soniadesor
21.11.2020 06:35

a = int(input())

for i in range(a):

 b = input()

 c = 0

 d = True

 e = 0

 f = False

 g = False

 h = '\''

 for j in b:

   if j == '#' and not f:

     g = True

     break

   elif j != ' ':

     if d:

       print(' ' * c, end='')

     elif c > 0:

       print(' ', end='')

     c = 0

     print(j, end='')

     if(j == '\"' or j == '\'') and e % 2 == 0:

       if f and j == h:

         f = False

       else:

         f = True

         h = j

     if f:

       d = True

     else:

       d = False

     if j == '\\':

       e += 1

     else:

       e = 0

   else:

     c += 1

   r = j == ' '

if g and c > 1:

 print(' ', end='')

if i < a - 1:

 print()

1

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота