minis551
25.01.2023 01:54

PROGRAM Z1; Образец
VAR A, H: INTEGER;
S: REAL;
BEGIN
WRITELN (‘ВВЕДИ ОСНОВАНИЕ ТРЕУГОЛЬНИКА’);
READLN (A);
WRITELN (‘ВВЕДИ ВЫСОТУ ТРЕУГОЛЬНИКА’);
READLN (H);
S:=A*H/2;
WRITE (‘ПЛОЩАДЬ ТРЕУГОЛЬНИКА РАВНА ‘, S);
END.
Составьте программы, которые позволят решать задачи:
1) Вычислить периметр треугольника
Переменные:
А, В, С – стороны треугольника (целые числа)
P – периметр (целое число)
Входные данные Выходные данные
3
4
5
12
2) Вычислить периметр и площадь квадрата
Переменные:
А - сторона квадрата (целые числа)
P – периметр квадрата (целое число)
S – площадь квадрата (целое число)
Входные данные Выходные данные
3 12
9
3) Вычислить площадь трапеции
Переменные:
А, В – основания трапеции (целые числа)
H – высота трапеции (целое число)
S – площадь трапеции (вещественное число)
Входные данные Выходные данные
10
7
4
34

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
radmirnemyshov
12.08.2020 03:23

ля представления различных классов линий в CorelDRAW предусмотрено несколько классов объектов. Объекты объединяются в один класс по признакам общей структуры и поведения, то есть реакции на действия с ними. При этом действия с линиями, которые представляют собой, например, изображение лица на портрете и размерную схему на чертеже, существенно отличаются друг от друга.

Модель кривой

В основе принятой в CorelDRAW модели линий лежат два понятия: узел и сегмент.

Узлом называется точка на плоскости изображения, фиксирующая положение одного из концов сегмента. Сегментом называется часть линии, соединяющая два смежных узла. Узлы и сегменты неразрывно связаны друг с другом: в замкнутой линии узлов столько же, сколько сегментов, а в незамкнутой - на один больше.

Любая линия в CorelDRAW состоит из узлов и сегментов, и все операции с линиями на самом деле представляют собой операции именно с ними. Узел полностью определяет характерпредшествующего ему сегмента, поэтому для незамкнутой линии важно знать, который из двух ее крайних узлов является начальным, а для замкнутой - направление линии (по часовой стрелке или против нее). По характеру предшествующих сегментов выделяют три типа узлов: начальный узел незамкнутой кривой, прямолинейный (Line) и криволинейный (Curve). На рис. 1 промежуточный узел 1 и конечный узел - прямолинейные, а промежуточный узел 2 - криволинейный.

В средней части строки состояния для кривой выводится обозначение класса объекта - (Кривая на слое 1), а также количество узлов этой кривой.

Объяснение:

0,0(0 оценок)
Ответ:
влад2610
12.05.2021 23:11

Современный прогресс человечества связан в первую очередь с глобальной информатизацией всего мирового сообщества. Уместно отметить, что современные компьютерные сети являются системой, возможности и характеристики которой в целом существенно превышают соответствующие показатели простой суммы составляющих элементов сети персональных компьютеров при отсутствии взаимодействия между ними.

Достоинства компьютерных сетей обусловили их широкое распространение в информационных системах кредитно-финансовой сферы, органов государственного управления и местного самоуправления, предприятий и организаций. Компьютерная сеть - объединение нескольких ЭВМ для совместного решения информационных, вычислительных, учебных и других задач.

Все компьютерные сети без исключения имеют одно назначение-обеспечение совместного доступа к общим ресурсам. Слово ресурс очень удобное. Ресурсы бывают трех видов: аппаратные, программные, информационные.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота