ladysweet1
01.12.2020 11:08

Напишите программу на Pascal: Напишите среднее значение целых положительных чисел, которые вводятся с клавиатуры (окончание ввода-ввод числа 0)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nurpaik
15.10.2020 05:01

//Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

ТАК) (Я НЕСОВСЕМ УВЕРЕН)

0,0(0 оценок)
Ответ:
nekrasovlesha1
15.10.2020 05:01

--- PascalABC.NET 3.6.2 ---

begin

 ReadSeqIntegerWhile(p -> p <> 0).Where(p -> p > 0).Average.Println;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота