Lups
06.06.2023 20:01

1)написать программу, которая описывает переменные как вещественные и вводит с клавиатуры скорость (v) и время (t) равномерного движения тела, рассчитывает и выводит на экран значение расстояния (s), пройденного телом за это время. 2)написать программу, которая описывает переменные как целые и вводит с клавиатуры длины сторон прямоугольника (a и b), рассчитывает и выводит на экран значение периметра (переменная p целого типа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Оленька090
09.05.2023 21:43
//Pascal ABC.NET v3.0 сборка 1111

type
 ty=set of char;

Const
 t:ty=['a','b','c','d','e','f','g','h','i','j','k','l','m','n','o','p','q','r','s','t','u','v','w','x','y','z','A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'];

Var
 f:text;
 s:string;
 i,slo,ks:integer;
 k:real;
begin
 assign(f,'text.in');
 reset(f);
 while not Eof(f) do read(f,s);
 close(f);
 slo:=0;
 ks:=0;
 for i:=1 to length(s) do
 if s[i] in t then inc(slo) else
  begin;
   k:=k+slo;
   inc(ks);
   slo:=0;
  end;
 if s[length(s)] in t then
  begin;
   inc(ks);
   k:=k+slo;
  end;
 k:=k/ks;
 assign(f,'text.out');
 rewrite(f);
 write(f,k);
 close(f);
 end. 

Пример ввода(text.in):
SIMPLE text
Пример вывода(text.out):
5
0,0(0 оценок)
Ответ:
Andreораидзпч
10.07.2021 03:04

объяснение:

робочою книгою; b. робочим аркушем; c. документом

14. принциповою відмінністю електронної таблиці від звичайної є:

a. можливість автоматичного перерахунку за формулами даних при зміні вихідних;

b. можливість обробки даних, структурованих у вигляді таблиці;

c. можливість наочного представлення зв'язків між опрацьовуваними даними;

d. можливість обробки даних, представлених у рядках різного типу.

15. вираз 3(а1+в1): 5(2в1-3а2), записаний у відповідності до правил, прийнятих в

і, в електронній таблиці має вигляд:

а) 3*(а1+в1)/(5*(2*в1-3*а2)); б) 3*(а1+в1)/5(2в1-3а2);

в) 3(а1+в1): 5*(2в1-3а2); г) 3(а1+в1)/(5(2в1-

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота