ekimmail631
14.03.2020 03:56

очень Составить программу на языке Паскаль и записать в тетрадь по алгоритму

Алгоритм решения линейного уравнения ах=в, где а и в произвольные вещественные числа

алг линейноеуравнение

арг а,в

рез х,у

нач

если а≠0

то у:= «есть решение» х:=в/а

иначе если в=0 то у:= «х-любое число» иначе у:= «решений нет»

всё

всё

кон

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
хзхзхзхззз
30.08.2020 08:19

var

a, b, x,y:Real;

begin

ReadLn(a, b);

if (a<0) or (a>0) then

begin

y:= b/a;

WriteLn(y);

end

else if (b<0) or (b>0) then

WriteLn('Решений нет')

else

WriteLn('x-любое число');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота