Alena201859
18.06.2020 04:00

Разработать на Паскаль программу для вычисления:

1) значения заданного арифметического выражения

2) значения заданной функции

c = x^2+y^2+sin(x), при x-y=0;(x-y)^2+cos(x), при 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Бако777
13.08.2022 05:34
1.сколько цветов будет содержать палитра, если каждый базовый цвет кодировать двумя битами?
 2^2=4
2.Какой объем видеопамяти в в кбайтах нужен для хранения изображения размером 640х250 пикселей и используещего 16-цветную политуру ?
16=2^4
640*250*4= 640000 бит=  640000/8 байт=80000/1024Кб=78,125Кб
3.видеопамять имеет объем, в котором может хранится 4-х цветное изображение размером 300х200.
Какого размера изображение можно хранить в том же объеме памяти, если оно будет использовать 256-ти цветную палитру?
300х200*2=120000 бит
256=2^8
120000бит/8= 15000 -> Ширина*высоту <= 15000 пискселей, например 150*100
4.Сколько цветов можно максимально использовать для хранения изображения размером
350x200 пикселей если объем страницы видеопамяти 65 кбайт
65кб/(35*200)=65кб/(35*200)*8*1024=76,06857143
76>=2^6 -> кол-во цветов 6
5.Пусть видеопамять компьютера имеет объем 512 кбайт.
Размер графической сетки 640x480.
Сколько страниц может одновременно разместиться в видеопамяти при палитре из 256 цветов?
256=2^8
8*640*480=2457600 бит=300кб
Таким образом одна страница
0,0(0 оценок)
Ответ:
AriPanowa2005
17.12.2022 00:24
#include
необходим для подключения заголовочных файлов из стандартной библиотеки C/C++ (в этом случае название заголовочного файла указывается в угловых скобках, например, #include <cstdlib>) или заголовочных файлов сторонних библиотек (в этом случае название указывается в двойных кавычках, например, #include "sqlite3.h").

using namespace std
используется для выбора пространства имён std по-умолчанию. В библиотеках могут быть использованы различные пространства имён, ограничивающие область видимости функций, классов и глобальных переменных. В стандартной библиотеке используется пространство имён std, указывающее на то, что данная конструкция является частью стандартной библиотеки. Если не использовать никакое пространство имён, то даже при подключении заголовочного файла (например применив вызов #include <iostream>), мы не сможем явно использовать элементы этой библиотеки, которые объявлены в пространстве имён std. Т.е. вызов cout << "Привет, мир!" вызовет ошибку, что объект cout не найден. Это происходит потому, что данный объект имеет область видимости только внутри пространства имён std. Но мы можем его вызвать, явно указав, в каком пространстве имён следует искать данный объект. Для этого необходимо перед именем объекта указать имя пространства имён, в котором он находится. Пример:

#include <iostream>

int main()
{
     cout <<"Hello!"  // Ошибка - не указано пространство имён
     std::cout  <<"Hello!"  // Нет ошибки - вызов объекта из пространства имён std, указанного явным образом
}

как-то так...
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота