arina1234as
08.06.2020 09:47

Составьте программу, определяющую максимальное из всех вводимых вами чисел. концом ввода чисел является введенное число 0. для проверки подготовить код программы и результаты ее работы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
9109160145davla
09.06.2020 09:56
Код программы

program raf105;

var a,max:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

a:=1;

while a<>0 do

begin

 readln(a);

 if a>max

   then max:= a;

end;

writeln('Максимальное число: ',max);

end.

Результаты работы программы

Вывод:

Вводите числа по очереди

чтобы закончить введите 0

Ввод:

12

1

100

99

105

104

2

3

0

Вывод:

Максимальное число: 105

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота