polina120805
04.09.2020 18:16

Номер 1 Найдите соответствия:

1 program p2 1Процедура вывода на экран

2 var a,b,c:integer 2Процедура ввода с клавиатуры

3 begin 3 Заголовок программ

4 realdnl (a,b) 4 Конец раздела операторов

5 c:=a+b 5 Раздел операторов

6 writeln ('c=',c); 6 Оператор присваивания

7 end 7 Начало раздела операторов

Номер 2

Что будет выведено на экран в результате выполнения первого задания ,если с клавиатуры вывести 7 3 ?

Что означает найденная величина?

Номер 3

Из задания номер один выпишите лексические единицы :

1Ключевые слова

2Индефекаторы

3Строки символов

Номер 4

Составьте из символов f 4 5 .E a 9 по два примера лексических единиц:

1 целые числа

2 вещественые числа

3 индификаторы

4 строки символов

Номер 5

Напишите на языке Паскаля выражение:

2а (во второй степени)+с

- с (во второй ст)

а+5с

Номер 6

Написать программу ,которая находит пересмотр и площадь ,если с клавиатуры вводят длины сторон .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
fernandus
03.06.2022 02:17
P.S.

Тернарная операция в C++ - это выражение вида (b ? x : y) (где b - логическое выражение, а x и y - одного типа). Она вернёт x, если выражение b истинно, и y, если b ложно.


Решение

В приложении расписаны координаты некоторых клеток, а также помечены точками те, которые по цвету отличаются от не помеченных. Если поискать, что у них общего, можно обнаружить, что у "невыколотых" клеток сумма координат по горизонтали и вертикали - чётная. Это "свойство" и используем для определения цвета клетки.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

 int x1, y1, x2, y2;

 cin >> x1 >> y1 >> x2 >> y2;

 cout << ((x1 + y1) % 2 == (x2 + y2) % 2 ? "YES" : "NO") << endl;

 return 0;

}



На с++ с тернарной операцией поле шахматной доски определяется парой натуральных чисел, каждое из ко
0,0(0 оценок)
Ответ:
olechka162
03.06.2022 02:17

Давай сравним все 4 числа между собой, найдём максимальное и вычтем из него N.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a, b, c, d, n;

   cin >> a >> b >> c >> d >> n;

   if (a > b && a > c && a > d)

       a -= n;

   else if (b > a && b > c && b > d)

       b -= n;

   else if (c > a && c > b && c > d)

       c -= n;

   else d -= n;

   cout << a << " " << b << " " << c << " " << d << endl;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота