АртемGoloborshev
22.07.2020 14:15

Проверочный тест «Программирование на языке Паскаль»
Вариант 2

2. Определите тип чисел: 1.8, 1.0, 41

4. Определите значение переменной b после выполнения алгоритма
a:=3;
b:=2+a;
a:=b*2*a;
b:=2*a-b;
5. Определите результат выполнения операции 15 mod 3
6. Определите, что будет напечатано в результате выполнения следующего алгоритма
var k,m:integer;
dat: array[1..10] og integer;
begin
dat[1]:=45; dat[2]:=55; dat[3]:=40; dat[4]:=15; dat[5]:=20; dat[6]:=80;
dat[7]:=35; dat[8]:=70; dat[9]:=10; dat[10]:=45;
m:=dat[1];
for k:=2 to 10 do begin
if dat[k] begin
m:=m+dat[k]; ;
end;
end;
write (m);
end.
7. Сколько существует заполнения массива? Перечислите их.
8. Напишите, используя алгоритмический язык или ЯП Pascal, алгоритм проверки
четности числа.
9. Составьте программу, которая в одномерном массиве размерностью 15 (элементы
массива случайные числа из промежутка от 0 до 9) находит количество элементов
равных 3. Оформите вывод элементов на экран в строчку, количество искомых
элементов на следующей строке хоть с чем нибудь

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Денок07
05.11.2020 20:19
Uses Crt;
const
  n=10;
var
  a,b:array[1..n] of integer;
  i,k,t:integer;
begin
  ClrScr;
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(50);
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do begin
    b[i]:=Random(50);
    Write(b[i],' ')
    end;
  Writeln;
  Write('k t='); Read(k,t);
  for i:=1 to n do begin
    if a[i]>t then a[i]:=a[i]+4;
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do begin
    if b[i]>10*k then b[i]:=b[i]+k;
    Write(b[i],' ')
    end;
  Readkey
end.

Тестовое решение:
1 6 23 12 47 1 44 24 6 18
31 30 30 29 0 3 43 32 46 21
k t=2 20
1 6 27 12 51 1 48 28 6 18
33 32 32 31 0 3 45 34 48 23
0,0(0 оценок)
Ответ:
mrazamar0kk
05.11.2020 20:19
var  mas1, mas2: array[0..9] of integer;  t, k, i, j: integer; 
begin  
readln(t);  
readln(k);  
for j := 0 to 1 do  begin   
      if (j = 1) then writeln();        
                 for i := 0 to 9 do    begin      
                          if(j = 0) then begin       
                                  mas1[i] := random(100);        
                                    write(mas1[i], ' ');       
                                    if mas1[i] > t Then mas1[i] := mas1[i] + 4;      
                              end      
                            else 
                               begin       
                                      mas2[i] := random(100);        
                                      write(mas2[i], ' ');       
                                       if mas2[i] > 10 * K Then         
                                            mas2[i] := mas2[i] + K;      
                                end;    
                       end;       
                  for i := 0 to 9 do     
                         if (j = 0) then 
                               write(mas1[i]) 
                        else 
                                write(mas2[i]);    
               writeln();  
           end;  
readln();
end.

))
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота