Gaky
30.12.2022 17:10

Tasm
Напишите программу, которая складывает поэлементно два массива X и Y и помещает результат в массив Z. Размер элементов – 8 байт (длинное вещественное), количество элементов – 20.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lyn8023
12.06.2022 03:38

язык программирования python

summ = 0

pro = 0

first = True

N = int(input('Введите N: '))

K = int(input('Введите K: '))

M = int(input('Введите M: '))

str_A = input('Введите последовательность a через пробел: ').split()

A = [int(item) for item in str_A]

for i in range(1, N + 1, 2):

   if A[i] % K != 0 and A[i] % M == 0 and first:

       first = False

       summ = A[i]

       pro = A[i]

   elif A[i] % K != 0 and A[i] % M == 0 and not(first):

       summ += A[i]

       pro *= A[i]

print('Сумма: ' + str(summ))

print('Произведение: ' + str(pro))

0,0(0 оценок)
Ответ:
jil356
16.01.2021 23:45

2)

var s1, s2:string;

i: integer;

begin

   s1:='symbols';

   s2:='';

   

   i:=2;

   while i <= length(s1) do

   begin

       s2 += s1[i];

       i += 2;

   end;

   writeln(s2);

end.

4)

var sWord: string;

i, j: integer;

begin

   sWord:='moloko';

   for i:=1 to length(sWord) do

       for j:=length(sWord) downto i+1 do

           if sWord[j] = sWord[i] then

               delete(sWord, j, 1);

   write(sWord);

end.

5)

var text: string;

begin

   text:='Напечатает только это, а это не напечатает';

   writeln(LeftStr(text, pos(',', text) - 1));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота