taisia20061
24.04.2022 03:01

Составить программу, которая по введенному числу(в двоичной системе счисления) представляющего собой упакованную заданную структуру, формирует из нее составные части и выводит из на экран(в виде десятичного и двоичного числа).
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
O O O O O C D N N N N N N N N N ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zFast88
12.01.2023 10:59
Четное число кратно 2, а если оно кратно и 3, то оно кратно 2х3=6.

// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  if ReadSeqIntegerWhile('Ввод завершите нулем:',t->t<>0).Any(t->t mod 6=0)
  then Writeln('YES') else Writeln('NO')
end.

Примеры
Ввод завершите нулем: -45 34 23 17 -62 15 0
NO

Ввод завершите нулем:  -45 34 23 17 -62 12 15 0
YES

Замечание. Количество вводимых чисел не ограничено, поскольку они в памяти не хранятся. Числа не должны превышать 2 147 483 647.
0,0(0 оценок)
Ответ:
superbest
27.09.2022 20:19
//Pascal
var
  A: array[1..10] of integer;
  i, Count: byte;
  sum: integer;
begin
  randomize;
  writeln('Сгенерированный массив');
  for i := 1 to 10 do
  begin
    A[i] := random(8)-3;
    if A[i] < 0 then
      sum := sum + A[i];
    write(A[i],' ');
  end;
  writeln;
  writeln('Сумма отрицательных элементов = ', sum);
  writeln;
  writeln('Измененный массив');
  for i := 1 to 10 do
  begin
    if A[i] >= 0 then
    begin
      A[i] := 0;
      Count := Count + 1;
     end;
    write(A[i], ' ');
  end;
  writeln;
  writeln('Количество нулевых элементов = ', Count);
end.

Массив из 10 элементов заполнить случайными числами от - 3 до 4 включительно. найти сумму отрицатель
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота