MaxCraft670
13.12.2020 23:36

Задание 3 Напишите на алгоритмическом языке программу «Наибольшее из
трёх чисел».
1 ветвление: если (а>в) и (а>к) то с:=а
(аналогично, 2 отдельных ветвления для в, к)
УМОЛЯЮ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kosmikanna
10.04.2021 04:55

#include <iostream>

#include <cmath>

using namespace std;


double Otr(double Ax, double Bx, double Ay, double By) {

return sqrt((Bx - Ax)*(Bx - Ax) + (By - Ay)*(By - Ay));

}


int main() {

double Ax, Ay, Bx, By, Cx, Cy, Dx, Dy;

cin >> Ax >> Ay >> Bx >> By >> Cx >> Cy >> Dx >> Dy;

cout << "|AB|=" << Otr(Ax, Bx, Ay, By) << endl;

cout << "|AC|=" << Otr(Ax, Cx, Ay, Cy) << endl;

cout << "|AD|=" << Otr(Ax, Dx, Ay, Dy) << endl;

return 0;

}


Написать программу в с++ описать функцию otr(ax,bx,ay,by) вещественного типа находящую длину отрезка
0,0(0 оценок)
Ответ:
Demon211108
03.05.2022 04:54

program xyz;

var

 D: array [1..25] of Integer;

 i, imin, imax, amin, amax, s, p: Integer;

 aver: Double;

begin

 Randomize;

 WriteLn ('Массив:');

 for i := Low (D) to High (D) do begin

   D [i] := Random (101);

   Write (D [i], ' ');

 end;

 imin := Low (D);

 imax := Low (D);

 amin := D [Low (D)];

 amax := D [Low (D)];

 s := 0;

 for i := Low (D) to High (D) do begin

   s := s + D [i];

   if D [i] < amin then begin

     amin := D [i];

     imin := i;

   end;

   if D [i] > amax then begin

     amax := D [i];

     imax := i;

   end;

 end;

 Aver := s / 25;

 p := 1;

 for i := Low (D) to High (D) do begin

   if D [i] > Aver then

     p := p * D [i];

 end;

 WriteLn;

 WriteLn ('Минимальное значение = ', amin);

 WriteLn ('Индекс = ', imin);

 WriteLn ('Максимальное значение = ', amax);

 WriteLn ('Индекс = ', imax);

 WriteLn ('Среднее арифметическое = ', aver :10 :5);

 WriteLn ('Произведение = ', p);

 ReadLn;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота