ксе16
15.11.2021 13:49

C++ Нарисовать блок-схему и написать программу для решения задач:
1. Дано число. Если оно меньше 7, то вывести Yes, если больше 10, то вывести No, иначе вывести Error.

2. Даны два числа. Если первое число больше второго, то вывести yes, иначе поменять значения этих переменных и вывести их на экран.

3. Даны два числа. Определить, являются ли числа одного знака или хотя бы одно из них равно нулю. (Подсказка: чтобы определить какого знака числа, нужно посмотреть на их произведение)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Пётр75
24.08.2020 18:18

1 задача:

#include <bits/stdc++.h>

using namespace std;

int main() {

   long long a;

   cin >> a;

   if (a < 7) cout << "Yes";

   else if (a > 10) cout << "No";

   else cout << "Error";

   return 0;

}

2 задача:

#include <bits/stdc++.h>

using namespace std;

int main() {

   long long a, b;

   cin >> a >> b;

   if (a > b) cout << "yes";

   else {

       long long c = a;

       a = b;

       b = c;

       cout << a << ' ' << b << endl;

   }

   return 0;

}

3 задача:

#include <bits/stdc++.h>

using namespace std;

int main() {

   long long a, b;

   cin >> a >> b;

   if (a * b >= 0) cout << "YES";

   else cout << "NO";

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота