saidovabduraxm
01.06.2022 23:58

б
1 напишите программу, которая вычисляет сумму первых n натуральных чисел (Задать цикл при n=10, числа х задаются с клавиатуры

2 напишите программу, которая выводит на экран таблицу умножения на n(n- целое число в диапазоне от 2 до 8, вводимое с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Пример на языке с++, дошел только для этого

#include<iostream>

using namespace std;

int min(int a, int b, int c, int d)

{

 int min1 = 0;

 int min2 = 0;

 if (a < b)

 {

  min1 = a;

 }

 else

 {

  min1 = b;

 }

 if (c < d)

 {

  min2 = c;

 }

 else

 {

  min2 = d;

 }

 if (min1 < min2)

 {

  cout << "Наименьшее из чисел: " << min1 << endl;

 }

 else

 {

  cout << "Наименьшее из чисел: " << min2 << endl;

 }

 return 0;

 

 

 

 

}

int main()

{

setlocale(LC_ALL,"RUSSIAN");

min(10,20,30,40);

 

return 0;

 

}

0,0(0 оценок)
Ответ:
Denis7788
22.06.2021 03:06
C++
#include <iostream>
#include <cmath>
#include <stdio.h>

using namespace std;
int main() {
int a,b,c,d,r,r2,r3;

cin >> a >> b >> c >> d;

r=min(a,b);
r2=min(r,c);
r3=min(r2,d);

cout << r3;
return 0;
}

Pascal
program Project1;

var a,b,c,d:integer;

begin
readln (a,b,c,d);

if ((a<=b) and (a<=c) and (a<=d)) then begin
writeln (a);
end

else if ((b<=a) and (b<=c) and (b<=d)) then begin
writeln (b);
end

else if ((c<=b) and (c<=a) and (c<=d)) then begin
writeln (c);
end

else begin
writeln (d);
end;

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота