bockovickof
18.10.2020 12:16

Составить программу на языке Паскаль, с оператора безусловного перехода. Написать программу, вычисляющую значение функции Z, Z=1/Х, если Х<=128 Z=1/(Х-200), если Х>128

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KimTaehyeng
27.06.2022 23:43
// PascalABC.NET 3.3, сборка 1542 от 05.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=8;
  var a:=new real[n,n];
  var k:=1;
  for var i:=0 to n-1 do
    for var j:=0 to n-1 do begin
      if i.IsEven then a[i,n-1-j]:=k
      else a[i,j]:=k;
      k+=1
      end;
  a.Println(3,0)
end.

Результат
  8  7  6  5  4  3  2  1
  9 10 11 12 13 14 15 16
 24 23 22 21 20 19 18 17
 25 26 27 28 29 30 31 32
 40 39 38 37 36 35 34 33
 41 42 43 44 45 46 47 48
 56 55 54 53 52 51 50 49
 57 58 59 60 61 62 63 64
0,0(0 оценок)
Ответ:
ЬПОАСИ
18.04.2022 14:52
// PascalABC.NET 3.2, сборка 1431 от 28.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20).Select(i->i/10).ToArray;
  Write('Массив: '); a.Println;
  Writeln('Сумма элементов с нечетными номерами: ',
    a.Where((x,i)->i.IsEven).Sum);
  var i1:=a.FindIndex(x->x<0);
  var i2:=a.FindLastIndex(x->x<0);
  Write('Вторая искомая сумма: ');
  if i2=i1 then Writeln(0)
  else Writeln(a[i1+1:i2].Sum);
  Write('Сжатый массив: ');
  a:=a.Where(x->abs(x)>1).ToArray; a.Println;
end.

Пример
n= 10
Массив: 1.8 0.2 1 -2 0.1 0.4 -1 1.2 -1.4 0.6
Сумма элементов с нечетными номерами: 0.5
Вторая искомая сумма: 0.7
Сжатый массив: 1.8 -2 1.2 -1.4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота