zhzdd
25.04.2020 16:26

Задание: Нарисовать блок схему и написать программу вычисления цикла с параметром.

Определите расчетную массу состава на подъеме с уклоном i (отношение высоты подъема к длине участка, умноженное на 1000) и радиусом кривой R для тепловоза ТЭЗ. Состав сформирован из четырехосных груженых вагонов массой q; масса тепловоза P =252 т.

Математическая формулировка задачи.

Удельное сопротивление четырехосных вагонов массой g определяется по формуле

W1=7,7+(8,0+0,1V+0,0025V2)/g/4

Удельное дополнительное сопротивление в зависимости от уклона и радиуса кривой

i0=i +700/R

масса состава рассчитывается следующим образом:

Q=(F-P(W0+i0))/(W1+i0)

Алгоритм решения задачи.

1. Ввод исходных данных R,i,g и F и W0.

2. Вычисление i0.

3. Организация цикла по V от 1 до 60 с шагом 1.

4. Вычисление W1, Q.

5. Вывод результатов Q.

6. Конец цикла.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lagunahey
15.01.2021 23:35

program Vozrasr;



var


 AGE: integer;//Переменная возраста



begin


 writeln('Введите любое число от 1 до 120');


 Readln(AGE); //Ввод возраста


 if (AGE < 1) or (AGE > 120) then


begin


   writeln('ERROR!')


end


 else


 begin


   case AGE of  //для чисел от 11 до 20 создаем отд-ый кейс


     11..20: Writeln('ответ: Мне ', AGE, ' лет');


   Else    //иначе если они не входят в диапазон от [11..20], то выполняется второй кейс


     begin


       case AGE mod 10 of     //делим на 10 и получаем остаток =


         1: Writeln('ответ: Мне ', AGE, ' год');


         2..4: Writeln('ответ: Мне ', AGE, ' года');


         0, 5..9: Writeln('ответ: Мне ', AGE, ' лет');


       end;


     end;


   end;


end;


end.

0,0(0 оценок)
Ответ:
daryamelikhova
07.04.2022 11:32

ответ: \overline A \lor \overline B.

Пошаговое объяснение:

Во-первых, как можно заметить, от C значение функции не зависит.

Особенно это хорошо видно на последних двух строчках. Если убрать переменную C, то получиться таблица из 4 строк:

A B F

0 0 1

0 1  1

1  0 1

1  1 0

Это таблица истинности для отрицания И:  \overline{A \land B} = \overline A \lor \overline B - ответ.

На этом можно было бы остановиться (проверить по таблице истинности с учётом бесполезного С), но сделаем ещё кое-что - выведем это шаг за шагом, докажем, что С - бесполезная и никому не нужная переменная.

Запишем то же выражение в совершенной конъюнктивной нормальной форме. Выберем стоки, которые обращают выражение в Ложь.

A B C F

1   1 0 0

1   1  1 0

Две строки - две скобки. Единица в таблице означает отрицание переменной в скобке. Получаем F = (\overline A \lor \overline B \lor \overline C) \land (\overline A \lor \overline B \lor C).

Тут уже видно, что переменная С на результат не влияет. Упростим и приведём это к выражению выше.

(\overline A \lor \overline B \lor \overline C) \land (\overline A \lor \overline B \lor C) = (\overline A \lor \overline B \lor \overline C) \land \overline A \lor (\overline A \lor \overline B \lor \overline C) \land \overline B \lor (\overline A \lor \overline B \lor \overline C) \land C =

= \overline A \land \overline A \lor \overline B \land \overline A \lor \overline C \land \overline A \lor \overline A \land \overline B \lor \overline B \land \overline B \lor \overline C \land \overline B \lor \overline A \land C \lor \overline B \land C \lor \overline C \land C =

= \overline A \lor \overline B \land \overline A \lor \overline C \land \overline A \lor \overline A \land \overline B \lor \overline B \lor \overline C \land \overline B \lor \overline A \land C \lor \overline B \land C \lor 0 =

= \overline A \lor \overline B \lor [(\overline B \land \overline A) \lor (\overline A \land \overline B)] \lor [(\overline C \land \overline A) \lor(\overline A \land C)] \lor [(\overline C \land \overline B) \lor (\overline B \land C)] =

= \overline A \lor \overline B \lor (\overline A \land \overline B) \lor \overline A \land (\overline C \lor C) \lor \overline B \land (\overline C \lor C) =

= \overline A \lor \overline B \lor (\overline A \land \overline B) \lor \overline A \lor \overline B =

= \overline A \lor \overline B \lor (\overline A \land \overline B) =

= [(\overline A \lor \overline A) \land (\overline A \lor \overline B)] \lor \overline B =

= [\overline A \land (\overline A \lor \overline B)] \lor \overline B =

= (\overline A \lor \overline B ) \land (\overline A \lor \overline B \lor \overline B) =

= (\overline A \lor \overline B ) \land (\overline A \lor \overline B) =

= \overline A \lor \overline B - ответ.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота