Xieb
11.01.2021 01:12

Задание 1. Перейдите на сайт онлайн-компилятор на языке Паскаль https://ideone.com/pvrq7o. Изучите его интерфейс.

Задание 2. Наберите код программы для сложения двух чисел( см. ниже. В {} – это комментарии, поясняющие, что происходит в той или записи, их записывать не надо. Только сам код) и запустите на выполнение.
Program Summa;

Var
number1,
number2,
rezult
:integer; {указывает тип целых чисел}
Begin

Writeln ('Введите первое число ');
{Выводим на экран символы, записанные между апострофами}
Readln (number1);
{Введенное пользователем число считываем в переменную number1}
Writeln ('Введите второе число ');
{Выводим на экран символы, записанные между апострофами}
Readln (number2);
{Введенное пользователем число считываем в переменную number2}
rezult := number1 + number2;
{Находим сумму введенных чисел и присваиваем переменной rezult}
Writeln ('Сумма чисел ', number1, ' и ', number2, ' равно ', rezult);
{Выводим на экран строчку, содержащую ответ задачи}
Readln;{Процедура задержки экрана}
End.
Найдите в этой программе заголовок, раздел описания переменных, признак начала программы, признак конца программы, тело программы, комментарий. ответьте на во Какое назначение переменных number1, number2, rezult?
2. Что обозначает строка: number1, number2, rezult : integer; ?
3. Если присвоить переменным number1 и number2 соответственно значение 5 и 7, то какую строчку выдаст компьютер при исполнении последней процедуры Write? Запишите ее в отчет.
4. Переведите с английского языка слова: Write, Read. Как вы думаете, что должен делать операторы с таким названием?
5. Как вы понимаете запись: readln(number1); ?
6. Чему равно значение переменной rezult после выполнения оператора: rezult := number1 + number2; ?
7. Что делает оператор присваивания в этой программе?

Задание 3. Измените программу, выполненную в задании 2 так, чтобы она находила произведение двух чисел. Проверьте работу программы с онлайн-компилятора по ссылке выше. Запишите в качестве ответа часть кода, в которую вы внесли изменения очень

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gax17003
03.03.2023 17:58

1) ((N mod 3=0) or (N mod 7=0)) and (N mod 5<>0)  

2) (((N mod 100) div 10)>((N mod 1000) div 100)) and (N mod 3=0)

3) (N mod 2=0) or ((N >400) and (N<500))

4) (N mod 6=0) and (N mod 7<>0)

5) ((N>9) and (N<100)) and ((N mod 10=6) or (N div 10=6) ))div 10))

6) (N mod 2=0) and (N mod 3=0)  

7) ((N>99) and (N<1000)) and (N mod 2<>0)

8) ((N>9) and (N<100)) and ((N div 10) mod 2=0)

9) ((N<=77) or (N>=88))  

10) (N mod 2<>0) or (N <=3) or (N mod 7<>0)  

11) ((a>9) and (a<100)) and (b>0)  

12) (a mod b=0) or (b mod a=0)

13) (((a mod 100) div 10) mod 2=0) and (((a mod 100) div 10) mod 2=0)  

14) (a*b) mod 3=0

15) ((a+b) mod 2=0) and ((a*b) mod 2<>0)  

16) ((a>9) and (a<100)) and (b<53)  

17) ((a mod 1000) div 100=2) or ((b mod 1000) div 100=2)

18) (a>0) or (b>0)

19) (a mod 10)>((a mod 100) div 10)  

20) (a>0) and (b>0)

0,0(0 оценок)
Ответ:
hunateВадим2827854
03.03.2023 17:58

 if (N mod 2 <> 0) and (N mod 3 = 0) then

 if ((N >= 345) and (N < 543)) or (N mod 7 = 0) then

 if (N mod 3 = 0) or (N mod 10 = 0) then

 if (N >= 231) and (N < 312) and (N mod 3 <> 0) then

 if (N mod 2 <> 0) and (N div 10 mod 10 <= 5) then

 if (N > 9) and (N < 100) and (N mod 10 = N div 10) then

 if (N mod 10 = 4) and (N div 100 mod 10 > 3) then

 if (N > 9) and (N < 100) and (N div 10 mod 2 <> 0) then

 if (N mod 2 = 0) and (N div 10 mod 10 > 5) then

 if (N > 99) and (N < 1000) and (N div 100 = 8) then

 if (a mod 2 = 0) or (b mod 2 = 0) then

 if (a + b > 56) and (a + b < 145) then

 if (a mod 10 = 6) and (b mod 10 = 6)

 if (a > 0) and (b > 9) and (b < 100) then  

 if (a div 10 mod 10 < 5) or (b div 100 mod 10 > 3) then  

 if (a mod 3 = 0) or (b mod 5 <> 0) then

 if (a > 0) and (b >= 0) then

 if (a > 100) or (b > 100) then  

 if (a mod 8 > 4) and (b mod 12 < 5) then  

 if (a mod 2 <> 0) and (b mod 2 <> 0) then

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота