dhdhdh1
01.11.2022 21:55

Написать программу на с++, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Использовать только библиотеку .

Примеры

входные данные
6
7 2 1 5 3 8

выходные данные
1 2 3 7 5 8

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Marinaaa01
05.01.2024 20:18
Хорошо, я с удовольствием помогу. Для решения этой задачи потребуется следующий подход:

1. Создайте массив и заполните его элементами, используя входные данные пользователя.
2. Используйте алгоритм сортировки для нахождения трех наименьших элементов массива. Например, можно использовать пузырьковую сортировку.
3. Создайте новый массив, который будет хранить отсортированный результат.
4. Сначала добавьте три наименьших элемента массива в новый массив, затем добавьте остальные элементы исходного массива.
5. Выведите новый массив на экран, чтобы убедиться в правильности решения.

Вот пример кода на C++, решающего данную задачу:

```cpp
#include
#include

int main() {
int n;
std::cout << "Введите размер массива: ";
std::cin >> n;

int arr[n];
std::cout << "Введите элементы массива: ";
for(int i = 0; i < n; i++) {
std::cin >> arr[i];
}

// Сортировка массива
std::sort(arr, arr + n);

int new_arr[n];
std::copy(arr, arr + n, new_arr);

// Перестановка трех наименьших элементов в начало массива
for(int i=0; i < 3; i++) {
std::swap(new_arr[i], new_arr[i+3]);
}

// Вывод результата
std::cout << "Отсортированный массив: ";
for(int i = 0; i < n; i++) {
std::cout << new_arr[i] << " ";
}
std::cout << std::endl;

return 0;
}
```

После запуска программы, она запросит у вас размер массива и элементы массива. Затем она выполнит все необходимые шаги, описанные выше, и выведет на экран отсортированный массив с тремя наименьшими элементами в начале.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота