kucharin
09.04.2020 07:54

Приветик друзья с кодом, а то никак не пойму как его записать на паскаль.
— Составить программу, которая формирует массив P из 24 элементов, в котором элементы с 1 по 10 являются кубами своих порядковых номеров, элементы с 10 по 24 равны периметрам квадратов со сторонами равными соответственно 10, 11,12, …, 24. Массив вывести в строку.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dinbili2
29.07.2020 19:08

ответ

2,0/5

2

yasadc

1)uses crt;

const m=5;

n=5;

var a:array[1..m,1..n] of integer;

b:array[1..m] of integer;

i,max,min,j,k,p:integer;

begin

randomize;

for i:=1 to m do

for j:=1 to n do

a[i,j]:=random(20);

min:=20;

max:=0;

for i:=1 to m do

begin

for j:=1 to n do

write(a[i,j]:3);

writeln;

end;

writeln;

k:=1;

repeat

for i:=k to k do

for j:=1 to n do

begin

if (a[i,j]<min) then begin min:=a[i,j]; b[k]:=a[i,j]; end;

end;

inc(k);

min:=20;

until k>n;

for p:=1 to m do

if (b[p]>max) then max:=b[p];

writeln(max);

end.

Объяснение:

0,0(0 оценок)
Ответ:
natalyaepishenk
04.11.2022 04:17

3

Объяснение:

Посчитаем количество участников по регионам:

Башкирия - 500

Чувашия - 600

Удмуртия - 900

Всего 2000

Следовательно Удмуртия занимает чуть меньше половины.

Рассмотрим диаграммы:

В 1 и 2 диаграммах один из регионов занимает ровно половину диаграммы (зелёный сектор). Они нам не подходят, т.к. самый большой регион должен занимать чуть меньше половины.

В 4 диаграмме все регионы занимают равные сектора, что тоже не соответствует условию. Она тоже не подходит.

В 3 диаграмме все условия выполнены. Она подходит.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота