revenko816mailru
16.11.2021 16:05

Расположите в правильном порядке строки программы:

1) S:=a*h;
6) var a,b,h,p,s: integer;
2) end.
7) readln;
3) program pr;
8) Writeln(‘p=’,p,’ s=’,s);
4) p:=(a+b)^2;
9) a:=5;b:=8;h:=3;
5) begin

2. Установите соответствие между служебными словами и названиями разделов программы:
а) Var а) Раздел операторов
b) Program b) Раздел имени программы
c) Uses c) Раздел описания переменных
d) Begin …end d) Раздел описания библиотечных модулей

3.. Определите значение переменной a после выполнения алгоритма:
а := 8
b := 2
b := a/2*b
a := 2*а + 3*b
В ответе укажите одно целое число — значение переменной a.

4.Запишите значение переменной y, полученное в результате работы следующей программы.
var y, i: integer;
begin
y := 0;
for i := 1 to 3 do
y := y + 4 * i;
writeln(y);
end.

5.Запишите значение переменной t, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
var t, i: integer;
begin
t := 2;
for i := 1 to 3 do
t := t * i;
writeln(t);
end.

​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
perrezz
09.06.2022 13:10

Объяснение:

Пошаговое объяснение:

Кажется, догадался.

1) Плывут взрослая горилла и взрослая шимпанзе. Горилла остаётся на том берегу. Шимпанзе возвращается.

2) Шимпанзе берет ребенка гориллы и перевозит. Оставляет ребенка на том берегу и возвращается.

3) Шимпанзе берет своего ребенка и перевозит. А в обратную дорогу берет ребенка гориллы и возвращает на этот берег.

В результате на 1 берегу оказывается ребенок шимпанзе, взрослая шимпанзе и два ребенка гориллы.

А на 2 берегу взрослая горилла и ребенок шимпанзе.

Всех поровну, никто никого не съел.

4) Шимпанзе забирает своего второго ребенка и перевозит на тот берег. Обратно возвращается горилла.

5 и 6) Горилла за два рейса перевозит обоих своих детей.

0,0(0 оценок)
Ответ:
elenavlodekp087wo
16.01.2023 16:02

ответ: Объяснение:

вариант 1

1.

100₂ = 0*2⁰ + 0*2¹ + 1*2² = 4₁₀

762₈ = 2*8⁰ + 6*8¹ + 7*8² = 498₁₀

FE₁₆ = 14*16⁰ + 15*16¹ = 254₁₀

2.

1050₁₀ = 0*2⁰ + 1*2¹ + 0*2² + 1*2³ + 1*2⁴ + 0*2⁵ + 0*2⁶ + 0*2⁷ + 0*2⁸ + 0*2⁹ + 1*2¹⁰ = 10000011010₂

1050₁₀ = 2*8⁰ + 3*8¹ + 0*8² + 2*8³ = 2032₈

1050₁₀ = 10*16⁰ + 1*16¹ + 4*16² = 41A₁₆

3.

1000000000₂ = 0*2⁰ + 0*2¹ + 0*2² + 0*2³ + 0*2⁴ + 0*2⁵ + 0*2⁶ + 0*2⁷ + 0*2⁸ + 1*2⁹ = 512₁₀ - меньше всех

1004₈ = 4*8⁰ + 0*8¹ + 0*8² + 1*8³ = 516₁₀

206₁₆ = 6*16⁰ + 0*16¹ + 2*16² = 518₁₀ - больше всех

517₁₀

4.

100₁₀₀ = 0*100⁰ + 0*100¹ + 1*100² = 10000₁₀

20₉₉ = 0*99⁰ + 2*99¹ = 198₁₀

5.

1001₂ = 1*2⁰ + 0*2¹ + 0*2² + 1*2³ = 9₁₀

1111₂ = 1*2⁰ + 1*2¹ + 1*2² + 1*2³ = 15₁₀

24₁₀ = 0*2⁰ + 0*2¹ + 0*2² + 1*2³ + 1*2⁴ = 11000₂

1001₂ + 1111₂ = 11000₂

56₈ = 6*8⁰ + 5*8¹ = 46₁₀

76₈ = 6*8⁰ + 7*8¹ = 62₁₀

108₁₀ = 4*8⁰ + 5*8¹ + 1*8² = 154₈

56₈ + 76₈ = 154₈

A0₁₆ = 0*16⁰ + 10*16¹ = 160₁₀

9F₁₆ = 15*16⁰ + 9*16¹ = 159₁₀

319₁₀ = 15*16⁰ + 3*16¹ + 1*16² = 13F₁₆

A0₁₆ + 9F₁₆  = 13F₁₆

вариант 2

1.

1000₂ = 0*2⁰ + 0*2¹ + 0*2² + 1*2³ = 8₁₀

552₈ = 2*8⁰ + 5*8¹ + 5*8² = 362₁₀

AB₁₆ = 11*16⁰ + 10*16¹ = 171₁₀

2.

2000₁₀ = 0*2⁰ + 0*2¹ + 0*2² + 0*2³ + 1*2⁴ + 0*2⁵ + 1*2⁶ + 1*2⁷ + 1*2⁸ + 1*2⁹ + 1*2¹⁰ = 11111010000₂

2000₁₀ = 0*8⁰ + 2*8¹ + 7*8² + 3*8³ = 3720₈

2000₁₀ = 0*16⁰ + 13*16¹ + 7*16² = 7D0₁₆

3.

1111101000₂ = 0*2⁰ + 0*2¹ + 0*2² + 1*2³ + 0*2⁴ + 1*2⁵ + 1*2⁶ + 1*2⁷ + 1*2⁸ + 1*2⁹ = 1000₁₀

1751₈ = 1*8⁰ + 5*8¹ + 7*8² + 1*8³ = 1001₁₀ - больше всех

3E7₁₆ = 7*16⁰ + E*16¹ + 3*16² = 999₁₀ - меньше всех

4.

200₁₀₀ = 0*100⁰ + 0*100¹ + 2*100² = 20000₁₀

10₉₉ = 0*99⁰ + 1*99¹ = 99₁₀

5.

1111₂ = 1*2⁰ + 1*2¹ + 1*2² + 1*2³ = 15₁₀

1101₂ = 1*2⁰ + 0*2¹ + 1*2² + 1*2³ = 13₁₀

28₁₀ = 0*2⁰ + 0*2¹ + 1*2² + 1*2³ + 1*2⁴ = 11100₂

1111₂ + 1101₂ = 11100₂

77₈ = 7*8⁰ + 7*8¹ = 63₁₀

56₈ = 6*8⁰ + 5*8¹ = 46₁₀

109₁₀ = 5*8⁰ + 5*8¹ + 1*8² = 155₈

77₈ + 56₈ = 155₈

FE₁₆ = 14*16⁰ + 15*16¹ = 254₁₀

AB₁₆ = 11*16⁰ + 10*16¹ = 171₁₀

425₁₀ = 9*16⁰ + 10*16¹ + 1*16² = 1A9₁₆

FE₁₆ + AB₁₆ = 1A9₁₆

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота