Taynik
08.11.2022 01:12

Паскаль: определить сколько раз встречается число k при генерации чисел с цикла for (элементы сгенерировать randomom)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladpasin34
09.06.2020 02:26

program raf105;

var n,k,i,raz:integer;

begin

write('Сколько чисел нужно сгенерировать?: ');

readln(n);

write('Число, которое нужно посчитать (k): ');

readln(k);

for i:=1 to n do

if (random(0,100))=k

 then raz:= raz+1;

writeln('Из ',n,' сгенерированных чисел число ',k,' встретилось ',raz,' раз');

end.

Язык программирования PascalABC

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота