dezlautekp0147d
04.09.2021 16:58

Напишите программу, которая находит частное (суммы всех четных чисел) / (Разность всех нечетных чисел), записанных в файле в столбик, и выводит результат в другой файл.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
polina9898798788
14.10.2020 20:37

#include <iostream>

using namespace std;

signed main() {

   freopen("input.txt","r",stdin);

   freopen("output.txt","w",stdout);

   int x;

   double sum = 0,dif = 0;

   while(cin >> x){

       if(x % 2 == 0)

           sum += x;

       else

           dif -= x;

   }

   cout << sum/dif;

   fclose (stdout);

}

0,0(0 оценок)
Ответ:
Семма0106
14.10.2020 20:37

// PascalABC.NET

begin

 var (se, so) := (0, 0);

 foreach var s in ReadLines('input.txt') do

 begin

   var t := s.ToInteger;

   if t.IsEven then

     se += t

   else

     so += t

 end;

 WriteAllText('output.txt', (se / so).ToString)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота