dramidontova
15.03.2021 11:43

Напишите программу на языке паскаль к этим , только не скопируйте тупо из 7 класс. заранее )​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Markizka22
18.02.2021 20:36
// PascalABC.Net 3.0, сборка 1052
const
  k=5;
  minT=-60;
  maxT=60;
  Umax=4.8;
var
  Ut,s,meanT:real;
  ring:array[1..k] of real;
  i,p:byte;
begin
  { Модерируем работу за 25 с }
  Randomize;
  s:=0;
  { Выход на рабочий режим }
  for i:=1 to k do begin
    Ut:=0.3*Random+3; { колебания напряжения от 3 до 3.3В }
    ring[i]:=minT+(maxT-minT)*Ut/Umax;
    s:=s+ring[i]
  end;
  meanT:=s/k;
  Writeln('t=',k:2,'c, средняя температура= ',meanT:6:2);
  { Рабочий режим }
  for i:=k+1 to 25 do begin
    Ut:=0.3*Random+3; { колебания напряжения от 3 до 3.3В }
    p:=i mod k; if p=0 then p:=k;
    s:=s-ring[p];
    ring[p]:=minT+(maxT-minT)*Ut/Umax;
    s:=s+ring[p];
    meanT:=s/k;
    Writeln('t=',i:2,'c, средняя температура= ',meanT:6:2);
  end
end.
 
Тестовое решение:
t= 5c, средняя температура=  19.61
t= 6c, средняя температура=  20.35
t= 7c, средняя температура=  20.60
t= 8c, средняя температура=  19.68
t= 9c, средняя температура=  20.03
t=10c, средняя температура=  19.17
t=11c, средняя температура=  18.06
t=12c, средняя температура=  17.16
t=13c, средняя температура=  18.15
t=14c, средняя температура=  18.01
t=15c, средняя температура=  18.25
t=16c, средняя температура=  19.44
t=17c, средняя температура=  19.71
t=18c, средняя температура=  18.80
t=19c, средняя температура=  18.54
t=20c, средняя температура=  19.36
t=21c, средняя температура=  19.57
t=22c, средняя температура=  20.20
t=23c, средняя температура=  20.65
t=24c, средняя температура=  20.97
t=25c, средняя температура=  20.46
0,0(0 оценок)
Ответ:
PolinaCat29
05.02.2020 11:54
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите три числа:');
  if b.Between(a,c) then (a,b,c):=(2*a,2*b,2*c);
  if (a<0) or (b<0) or (c<0) then (a,b,c):=(Abs(a),Abs(b),Abs(c));
  Writeln('a=',a,', b=',b,', c=',c)
end.

Пример
Введите три числа: 3.6 -5.2 8
a=3.6, b=5.2, c=8

Первый оператор читает с клавиатуры три вещественных числа и помещает их в переменные a,b,c.
Второй оператор проверяет, находится ли второе число (b) между остальными двумя (может и совпадать с одним из них). Если да, то значение каждой переменной удваивается.
Третий оператор проверяет, есть ли среди введенных чисел хоть одно отрицательное. Если есть, значения заменяются их модулями (становятся положительными).
И в конце следует вывод результатов.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота