kkarimov111
12.01.2023 14:51

Написать программу для решения : в параллели три 5-х класса. в б классе учится на 5 человек больше, чем в а. найдите, сколько человек учится в д классе, если всего в 5-х классах учится 80 человек.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Перрсик88
06.05.2023 18:00

1)

Дано:

I = 8 бит

Найти:

N - ?

N = 2^I\\N = 2^8 = 256

ответ: 256 чисел

2)

Дано:

I = 8 бит

Найти:

N - ?

N = 3^I\\N = 3^8 = 6\,561

ответ: 6 561 чисел

3)

Здесь пригодится комбинаторика, а именно правило размещения с повторениями:

\bar{A}_n^k = n^k\\\bar{A}_4^3 = 4^3 = 64

Также можно провести параллель с предыдущими заданиями:

I = 3\\N = 4^3 = 64

ответ: 64 трехбуквенных слова

4)

\bar{A}_x^3 = x^3 = 216\\\sqrt[3]{x^3} = \sqrt[3]{216}\\x = 6

ответ: мощность алфавита — 6 символов

5) Неразборчивое задание

6) Размер нового предложения стал на 16 байт меньше, следовательно, вычеркнутая строка "весит" 16 байт. Т.к. каждый символ кодируется 16 битами (16 / 8 = 2 байта) или 2 байтами, то было вычеркнуто 16 / 2 = 8 символов. Вычитаем из этого кол-ва символов один пробел и одну запятую, получается 8 - 2 = 6 символов — длина вычеркнутого слова. Название животного длиной 6 символов в тексте — тюлень.

ответ: тюлень

7) Размер нового предложения стал на 8 байтов меньше, следовательно, вычеркнутая строка "весит" 8 байтов. Т.к. каждый символ кодируется 8 битами (8 / 8 = 1 байт) или 1 байтом, то было вычеркнуто 8 / 1 = 8 символов. Вычитаем из этого кол-ва символов один пробел и одну запятую, получается 8 - 2 = 6 символов — длина вычеркнутого слова. Название реки длиной 6 символов в тексте — Москва.

ответ: Москва

8) Размер нового предложения стал на 28 байтов меньше, следовательно, вычеркнутая строка "весит" 28 байтов. Т.к. каждый символ кодируется 32 битами (32 / 8 = 4 байта) или 4 байтами, то было вычеркнуто 28 / 4 = 7 символов. Вычитаем из этого кол-ва символов один пробел и одну запятую, получается 7 - 2 = 5 символов — длина вычеркнутого слова. Название овоща длиной 5 символов в тексте — тыква.

ответ: тыква

0,0(0 оценок)
Ответ:
pomogite228plez
20.02.2021 04:45

pascal

Объяснение:

1)

const n = 20;

var i, s: integer;

   a: array[1..n] of integer;

begin

 randomize;

 for i := 1 to n do

 begin

   a[i] := random(31) - 15;

   Write(a[i], ' ');

   if a[i] > 9 then s := s + a[i];

 end;

 WriteLn;

 WriteLn('Сумма элементов, больших 9, равна ', s);

end.

2)

const n = 20;

var i, s: integer;

   a: array[1..n] of integer;

begin

 randomize;

 for i := 1 to n do

 begin

   a[i] := random(31) - 15;

   Write(a[i], ' ');

   if a[i] mod 2 = 0 then s := s + a[i];

 end;

 WriteLn;

 WriteLn('Сумма четных элементов равна ', s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота