Кate1257
08.06.2020 06:56

решить 5 задач на языке программирования Java Script:

1) Входные данные
Вводятся целые числа a и b. Гарантируется, что a не превосходит b
Выходные данные
Выведите (через пробел) все четные числа от a до b (включительно).
Примеры
входные данные
2
5
выходные данные
2 4

2) Входные данные
Вводятся 4 числа: a, b, c и d.
Выходные данные
Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.
Примеры
входные данные
2
5
0
2
выходные данные
2 4

3) Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число).
Входные данные
Вводится натуральное число x
Выходные данные
Выведите все делители числа x
Примеры
входные данные
32
выходные данные
1 2 4 8 16 32

4) Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите наименьший делитель числа x, отличный от 1.
Примеры
входные данные
6
выходные данные
2

5) Входные данные
Вводится число N, а затем N чисел, сумму которых необходимо вычислить.
Выходные данные
Выведите единственное число - сумму введенных чисел.
Примеры
входные данные
3
9
5
1
выходные данные
15

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Romikkk1
02.02.2021 07:44

В состав системного блока входят:

материнская плата

процессор

оперативная память

блок питания

внешний диск с данными.

Система охлаждения.

Доп устройства:

Видеокарта

SSD диски

Оптические диски.

Сетевые карты (в том числе Wi-Fi)

Тв-тюнеры, платы расширения USB, COM и других портов для подключения различных устройств

Модульный принцип позволяет потребителю самому комплектовать нужную ему конфигурацию компьютера и производить при необходимости ее модернизацию. ... Модульная организация компьютера опирается на магистральный (шинный) принцип обмена информацией между устройствами.

0,0(0 оценок)
Ответ:
CISA9999
27.02.2022 04:38

Вот код:

import random

# Сгенерируем список

lst = [random.randint(-30, 30) for _ in range(30)]

# 1

result = 1

for item in lst:

   if item < 0:

       result *= item

print(result)

# или

from functools import reduce

print(reduce(lambda x, y: x * y,

            filter(lambda item: item < 0, lst)))

# 2

max_count = 0

count = 0

for item in lst:

   if item < 0:

       count += 1

       if count > max_count:

           max_count = count

print(max_count)

# 3

result = 0

for item in lst:

   if item < 0:

       result += item

print(result)

# или

negative_nums = list(filter(lambda item: item < 0, lst))

print(sum(negative_nums) if negative_nums else "NO")

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота