наиб3
04.03.2022 06:40

Написать программу. которая проверяет попадание точки в заштрихованную область. На c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mondy228
26.03.2020 17:31

уточнять на каком языке программирования нужно написать задачки. Я же напишу на С++. Алгоритм везде будет один и тот же.

1 задача

int x1 = 0;

int x2 = 0;

int x3 = 0;

int x4 = 0;

int x5 = 0;

cin >> x1;

cin >> x2;

cin >> x3;

cin >> x4;

cin >> x5;

double sr = 0.0;

sr = (x1+x2+x3+x4+x5)/5;

Или же можно сделать по проще

int x = 0;

int sum = 0;

double sr = 0.0;

for(int i = 0; i<5; i++){

cin >> x;

sum = sum +x;

}

sr = sum/5;

2 Задача

int number = 5;

for(int i = 2; i<20; i=i+2){

number = number + i;

}

0,0(0 оценок)
Ответ:
Танюха1410
26.03.2020 17:31

#include <iostream>

using namespace std;

int main()
{
setlocale(LC_ALL, "Russian");
char key;
int i;
int a[255];
float arifm=0,sum=0,b=0;

cout << "Введите числа от а до б через пробел! (Условие: a < b)"<<endl;

for (i=0; i < 254; i++){
cin >> a[i];

if(i >= 1 && a[i] < a[i-1]){
break;
}
b++;
}

cout << "Получили числа: ";
for (i=0;i < b; i++){
cout << " " << a[i];
sum += a[i];
}
cout << endl<< "Сумма чисел = " << sum << endl;
arifm = sum / (b);
cout << "Среднее арифметическое = " << arifm << endl;
system ("pause");
}

 

Только не дописал выход из цыкла.. сейчас он при нарушение условия а < б
Если надо думаю справитесь с do while 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота