Dasha5746
30.01.2023 18:57

Напишите программу питон с решением s
иә-да,жоқ-нет

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
thetrueraincorn
21.09.2021 23:17
1. В "реальном мире" это решается примерно так:

// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
begin
  var a:=ArrRandom(ReadInteger('n='),0,2); a.Println;
  a.Sorted.Println
end.

Тестовое решение:
n= 15
1 2 0 2 2 0 2 0 2 0 0 1 0 0 2
0 0 0 0 0 0 0 1 1 2 2 2 2 2 2

2. Но, поскольку считается, что школьникам больше заняться нечем, их заставляют писать примерно в таком стиле (и время займет, и ощибок понаделают):

// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
const
  nn=100;
var
  i,j,n,t:integer;
  a:array[1..nn] of integer;
begin
  Write('n='); Read(n);
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(3);
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-1 do
      if a[j]>a[j+1] then begin
        t:=a[j]; a[j]:=a[j+1]; a[j+1]:=t
        end;
  for i:=1 to n do Write(a[i],' ');
  Writeln;
end.

Тестовое решение:
n=15
0 1 1 0 2 1 0 2 1 2 1 0 0 2 0
0 0 0 0 0 0 1 1 1 1 1 2 2 2 2
0,0(0 оценок)
Ответ:
galina6969
20.07.2022 23:15

на предыдущих уроках мы установили среду кумир, настроили ее для дальнейшей работы и научились задавать стартовую обстановку робота. теперь перейдем непосредственно к составлению алгоритмов для робота с использованием простых команд.

если вам больше нравится информация в формате видеоуроков, то на сайте есть видеоурок робот. простые команды.

у любого исполнителя должна быть система команд (ски — система команд исполнителя). система команд исполнителя — совокупность всех команд, которые может выполнить исполнитель. в качестве примера рассмотрим дрессированную собаку. она умеет выполнять некоторые команды — «сидеть», «лежать», «рядом» и т. п. это и есть ее система команд.

простые команды робота

у нашего робота тоже есть система команд. сегодня мы рассмотрим простые команды робота. всего их 5:

вверх

вниз

влево

вправо

закрасить

результат выполнения этих команд понятен из их названия:

вверх — переместить робота на одну клетку вверх

вниз — переместить робота на одну клетку вниз

влево — переместить робота на одну клетку влево

вправо — переместить робота на одну клетку вправо

закрасить — закрасить текущую клетку (клетку в которой находится робот).

эти команды можно писать с клавиатуры, а можно использовать горячие клавиши (нажав их команды будут вставляться автоматически):

вверх — escape, up (стрелка вверх)

вниз — escape, down (стрелка вниз)

влево — escape, left (стрелка влево)

вправо — escape, right (стрелка вправо)

закрасить — escape, space (пробел)

незнаю правильно или нет,если нет то сорян.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота